summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <brahmajit.xyz@gmail.com>2023-03-12 11:45:42 +0530
committerSam James <sam@gentoo.org>2023-03-13 18:02:15 +0000
commit89e287df0c13e7a249f1bb173129850ce7bdea23 (patch)
treeca76fdd89c09e8f64d59435a33b7bccda33cfd65 /app-editors
parentsys-kernel/gentoo-kernel-bin: Bump to 6.2.6 (diff)
downloadgentoo-89e287df0c13e7a249f1bb173129850ce7bdea23.tar.gz
gentoo-89e287df0c13e7a249f1bb173129850ce7bdea23.tar.bz2
gentoo-89e287df0c13e7a249f1bb173129850ce7bdea23.zip
app-editors/neovim: fix live ebuild darwin patch
Another upstream commit broke the darwin patch, this commit fixes it. Signed-off-by: brahmajit das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30070 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-darwin.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
index cdfb38c3fef4..cba966a4ebfa 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
@@ -1,9 +1,9 @@
--- a/src/nvim/CMakeLists.txt
+++ b/src/nvim/CMakeLists.txt
-@@ -440,10 +440,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${prop})
+@@ -394,10 +394,6 @@ foreach(gen_include ${prop})
list(APPEND gen_cflags "-I${gen_include}")
endforeach()
+ list(APPEND gen_cflags "-I${DEPS_PREFIX}/include")
-if(APPLE AND CMAKE_OSX_SYSROOT)
- list(APPEND gen_cflags "-isysroot")
- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")