summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-10-10 21:10:35 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-10 21:12:03 +0300
commitaba3fcc7e4a7554112486eef2ab210f3bba89998 (patch)
tree1f8b33a12b9f1606d5e487bbdf3983f63293eb76 /app-editors
parentprofiles/arch: drop stablemask on ugrd flag for installkernel (diff)
downloadgentoo-aba3fcc7e4a7554112486eef2ab210f3bba89998.tar.gz
gentoo-aba3fcc7e4a7554112486eef2ab210f3bba89998.tar.bz2
gentoo-aba3fcc7e4a7554112486eef2ab210f3bba89998.zip
app-editors/vscode: add 1.94.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.94.2.ebuild131
2 files changed, 134 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index bc203dbb4c71..38381c572ce4 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -10,3 +10,6 @@ DIST vscode-1.93.1-arm64.tar.gz 142212394 BLAKE2B 41c749fcfff253dcf9295429129c94
DIST vscode-1.94.1-amd64.tar.gz 145170000 BLAKE2B a791bdc8a4b89651349795bd3a44dd09cecefa9b6435810ee8f8760c8c25dc7cf3ceda75cf9432008e1404c0eec71d06f539ea0118a3bb1a7ad8c8fe16b680a6 SHA512 fe4cc2ee3bf936d992d9b8335bf3fdbe98a639a0f4b8b5d1bf7d88443d360d16298aa30dadd8f1be4b4200613e1dfa46d97187f58eba20c505dc317aeae9392c
DIST vscode-1.94.1-arm.tar.gz 129608752 BLAKE2B 72303ecff00985cf02c918c04dc59cad8f0834e5172b4c53b3db0e9973e8adf3e1f324faa95c17674d94161db64577797e6f78119eb75703a190c17d1f56c3a8 SHA512 fceaa5846a057da722cca123e11c54f87534679f7bc26d5d9c0ddf099bbd7e4c97d795a49fc8db6fbad66bde216676e8751a4424661762e38d9d9978ec12d133
DIST vscode-1.94.1-arm64.tar.gz 141301103 BLAKE2B 08f85077f6951a6d16db80d506b41fa7d9f615c599e159adde849e2bb94667aa344c953191d2911fd486c305453890aa4019d476579665d67c6b38e7a84bef13 SHA512 90616ba81470d029c5644f114a1918fcd1379cf1622a0474e9ff91928a7da1a6dfab204663b8d603b2c1e130ec6f6c7083493d3fcfdb131f0191a6de54e38d0d
+DIST vscode-1.94.2-amd64.tar.gz 145188698 BLAKE2B 0ba98d4af28da95d2d19b5cbb27b18a6c6f82a73c585e57ef94868133f595050b4ab1e78eb25d02a40fcf187057467e88f421e4e22544e301c709d2b1d590e0f SHA512 41f02fe383a825c0e50dae1a5527c2e62e6d8b930f62667a4ad17479264325f3a23bbf196a8ed5121a18bb9b3e853b7c840a0e1490157dc74adaa654bc566062
+DIST vscode-1.94.2-arm.tar.gz 129620768 BLAKE2B c31a0b60a8c0e6fcf6010846f29a1ed14804b20b5910d91e896e4f43f18ac26413f32f89546be1f5e68a4dcbcb24741369e8dd1f0d48436beb41e6b40c01da81 SHA512 37e541de5659b8a7097c54e5b7f6313a8e7f93691bbe640b302c1fc0c8588b8560c75e037d7a29df635bca47be791b29886c8171f5e15b0b76fc0e1069b68814
+DIST vscode-1.94.2-arm64.tar.gz 141296756 BLAKE2B 160dbbeea65cd482c42e7d48c120c63167fe274ebfab2c458923930aa9f5b69c005bbddd7d66139084809b73ff7ce04defc9421b738ef608a8f11a7385ee14ea SHA512 bba6212737b30f43ee943d3ab8883d6c184fe6e2f66375cb893521d766a75fb139664ea18f4e91436fb7863c5a72534b02a2d6aff6953c09085b5b5eec506064
diff --git a/app-editors/vscode/vscode-1.94.2.ebuild b/app-editors/vscode/vscode-1.94.2.ebuild
new file mode 100644
index 000000000000..7757235fed73
--- /dev/null
+++ b/app-editors/vscode/vscode-1.94.2.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* amd64 ~arm ~arm64"
+IUSE="egl kerberos wayland"
+RESTRICT="mirror strip bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+ kerberos? ( app-crypt/mit-krb5 )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ if ! use kerberos; then
+ rm -r ./resources/app/node_modules/kerberos || die
+ fi
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+
+ local EXEC_EXTRA_FLAGS=()
+ if use wayland; then
+ EXEC_EXTRA_FLAGS+=( "--ozone-platform-hint=auto" "--enable-wayland-ime" )
+ fi
+ if use egl; then
+ EXEC_EXTRA_FLAGS+=( "--use-gl=egl" )
+ fi
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code-url-handler.desktop" \
+ > "${T}/code-url-handler.desktop" || die
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code.desktop" \
+ > "${T}/code.desktop" || die
+
+ domenu "${T}/code.desktop"
+ domenu "${T}/code-url-handler.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "desktop notifications" x11-libs/libnotify
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}