summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-27 22:51:49 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-28 00:33:18 -0400
commite104aed53c7457e75370904e3d7d9b793239a375 (patch)
tree8bcef904b2c22c69c5138eb91e44e1388be01681 /app-editors
parentdev-python/opensearch-py: enable py3.13 (diff)
downloadgentoo-e104aed53c7457e75370904e3d7d9b793239a375.tar.gz
gentoo-e104aed53c7457e75370904e3d7d9b793239a375.tar.bz2
gentoo-e104aed53c7457e75370904e3d7d9b793239a375.zip
app-editors/gvim: delete untested code for USE=aqua
It was removed from vim upstream, 4 years ago in version 8.2.1422 via commit: https://github.com/vim/vim/commit/097148e849136b49052b1b5123c714fb1d74db9b The rationale was that it was "outdated" and "probably doesn't even work" -- sounds like they didn't know either. Their recommendation is that MacVim provides a gui version if you want one, and I guess vim just isn't gonna keep maintaining one??? Clearly no macOS users of Gentoo Prefix have tried enabling aqua for a very long time. This code logic is completely dead weight. This was noted as "I do not know" in a bug report about other toolkits that were dropped after aqua was ;) but nothing was done at the time... Bug: https://bugs.gentoo.org/858830 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/gvim-9.0.2167.ebuild23
-rw-r--r--app-editors/gvim/gvim-9.1.0366.ebuild23
-rw-r--r--app-editors/gvim/gvim-9.1.0470.ebuild23
-rw-r--r--app-editors/gvim/gvim-9999.ebuild23
4 files changed, 28 insertions, 64 deletions
diff --git a/app-editors/gvim/gvim-9.0.2167.ebuild b/app-editors/gvim/gvim-9.0.2167.ebuild
index 20fcedbb1b9e..9bd4c0338102 100644
--- a/app-editors/gvim/gvim-9.0.2167.ebuild
+++ b/app-editors/gvim/gvim-9.0.2167.ebuild
@@ -31,11 +31,10 @@ HOMEPAGE="https://www.vim.org https://github.com/vim/vim"
LICENSE="vim"
SLOT="0"
-IUSE="acl aqua crypt cscope debug lua minimal motif netbeans nls perl python racket ruby selinux session sound tcl"
+IUSE="acl crypt cscope debug lua minimal motif netbeans nls perl python racket ruby selinux session sound tcl"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
- aqua? ( !motif )
"
RDEPEND="
@@ -47,12 +46,10 @@ RDEPEND="
x11-libs/libXext
x11-libs/libXt
acl? ( kernel_linux? ( sys-apps/acl ) )
- !aqua? (
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- x11-libs/gtk+:3
- x11-libs/libXft
- )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
+ x11-libs/gtk+:3
+ x11-libs/libXft
)
crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
@@ -228,15 +225,9 @@ src_configure() {
)
fi
- # Default is gtk unless aqua or motif are enabled
+ # Default is gtk unless motif is enabled
echo ; echo
- if use aqua; then
- einfo "Building gvim with the Carbon GUI"
- myconf+=(
- --enable-darwin
- --enable-gui=carbon
- )
- elif use motif; then
+ if use motif; then
einfo "Building gvim with the MOTIF GUI"
myconf+=( --enable-gui=motif )
else
diff --git a/app-editors/gvim/gvim-9.1.0366.ebuild b/app-editors/gvim/gvim-9.1.0366.ebuild
index c4bccf290862..d5fb42570e67 100644
--- a/app-editors/gvim/gvim-9.1.0366.ebuild
+++ b/app-editors/gvim/gvim-9.1.0366.ebuild
@@ -31,11 +31,10 @@ HOMEPAGE="https://www.vim.org https://github.com/vim/vim"
LICENSE="vim"
SLOT="0"
-IUSE="acl aqua crypt cscope debug lua minimal motif netbeans nls perl python racket ruby selinux session sound tcl"
+IUSE="acl crypt cscope debug lua minimal motif netbeans nls perl python racket ruby selinux session sound tcl"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
- aqua? ( !motif )
"
RDEPEND="
@@ -47,12 +46,10 @@ RDEPEND="
x11-libs/libXext
x11-libs/libXt
acl? ( kernel_linux? ( sys-apps/acl ) )
- !aqua? (
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- x11-libs/gtk+:3
- x11-libs/libXft
- )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
+ x11-libs/gtk+:3
+ x11-libs/libXft
)
crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
@@ -228,15 +225,9 @@ src_configure() {
)
fi
- # Default is gtk unless aqua or motif are enabled
+ # Default is gtk unless motif is enabled
echo ; echo
- if use aqua; then
- einfo "Building gvim with the Carbon GUI"
- myconf+=(
- --enable-darwin
- --enable-gui=carbon
- )
- elif use motif; then
+ if use motif; then
einfo "Building gvim with the MOTIF GUI"
myconf+=( --enable-gui=motif )
else
diff --git a/app-editors/gvim/gvim-9.1.0470.ebuild b/app-editors/gvim/gvim-9.1.0470.ebuild
index 826999e81017..b27e70d458de 100644
--- a/app-editors/gvim/gvim-9.1.0470.ebuild
+++ b/app-editors/gvim/gvim-9.1.0470.ebuild
@@ -31,11 +31,10 @@ HOMEPAGE="https://www.vim.org https://github.com/vim/vim"
LICENSE="vim"
SLOT="0"
-IUSE="acl aqua crypt cscope debug lua minimal motif netbeans nls perl python racket ruby selinux session sound tcl"
+IUSE="acl crypt cscope debug lua minimal motif netbeans nls perl python racket ruby selinux session sound tcl"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
- aqua? ( !motif )
"
RDEPEND="
@@ -47,12 +46,10 @@ RDEPEND="
x11-libs/libXext
x11-libs/libXt
acl? ( kernel_linux? ( sys-apps/acl ) )
- !aqua? (
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- x11-libs/gtk+:3
- x11-libs/libXft
- )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
+ x11-libs/gtk+:3
+ x11-libs/libXft
)
crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
@@ -228,15 +225,9 @@ src_configure() {
)
fi
- # Default is gtk unless aqua or motif are enabled
+ # Default is gtk unless motif is enabled
echo ; echo
- if use aqua; then
- einfo "Building gvim with the Carbon GUI"
- myconf+=(
- --enable-darwin
- --enable-gui=carbon
- )
- elif use motif; then
+ if use motif; then
einfo "Building gvim with the MOTIF GUI"
myconf+=( --enable-gui=motif )
else
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index e5f30e3b3865..44b852c8973c 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -31,11 +31,10 @@ HOMEPAGE="https://www.vim.org https://github.com/vim/vim"
LICENSE="vim"
SLOT="0"
-IUSE="acl aqua crypt cscope debug lua minimal motif netbeans nls perl python racket ruby selinux session sound tcl"
+IUSE="acl crypt cscope debug lua minimal motif netbeans nls perl python racket ruby selinux session sound tcl"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
- aqua? ( !motif )
"
RDEPEND="
@@ -47,12 +46,10 @@ RDEPEND="
x11-libs/libXext
x11-libs/libXt
acl? ( kernel_linux? ( sys-apps/acl ) )
- !aqua? (
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- x11-libs/gtk+:3
- x11-libs/libXft
- )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
+ x11-libs/gtk+:3
+ x11-libs/libXft
)
crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
@@ -228,15 +225,9 @@ src_configure() {
)
fi
- # Default is gtk unless aqua or motif are enabled
+ # Default is gtk unless motif is enabled
echo ; echo
- if use aqua; then
- einfo "Building gvim with the Carbon GUI"
- myconf+=(
- --enable-darwin
- --enable-gui=carbon
- )
- elif use motif; then
+ if use motif; then
einfo "Building gvim with the MOTIF GUI"
myconf+=( --enable-gui=motif )
else