summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-07 22:31:01 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-07 23:21:56 +0100
commite8beec768dc756920633102ac5c138581b8e6d17 (patch)
tree29814ecb7b0c944b706c3833b302fa0f18711203 /app-emacs/auctex
parentdev-scheme/chez: bump to 10.0.0 (diff)
downloadgentoo-e8beec768dc756920633102ac5c138581b8e6d17.tar.gz
gentoo-e8beec768dc756920633102ac5c138581b8e6d17.tar.bz2
gentoo-e8beec768dc756920633102ac5c138581b8e6d17.zip
app-emacs/auctex: bump to 13.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/auctex')
-rw-r--r--app-emacs/auctex/Manifest1
-rw-r--r--app-emacs/auctex/auctex-13.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-emacs/auctex/Manifest b/app-emacs/auctex/Manifest
index e55a8b8350c9..3e76108093e4 100644
--- a/app-emacs/auctex/Manifest
+++ b/app-emacs/auctex/Manifest
@@ -1 +1,2 @@
DIST auctex-13.2.tar.gz 1667548 BLAKE2B 51daf18185a01c7349a49cfb3484d0271dc30271c69a028dc70ec9dae998b0664ffa574160dd384c35e66d38da95af5af0c4bf73e5ea969a6166685f8e3a0b80 SHA512 98d3d0061a807e62045b648a699e23819a0288ea17f2247b18c6725c503dfd6c791384c47504376de098b5a4e62bf350227497be6bf7a007fd94df232a069129
+DIST auctex-13.3.tar.gz 1695608 BLAKE2B 3a22273b72237e14a31a1fb9d81e2c4ee10290919bc3d6f8cb35ab877ef26083c7edb5bbb7c88a40f45848012cc2edd375a90d872f604029ba8f03278bd95f9a SHA512 32d6f3c968a27dd5e7862993419bfa0f5e5228abca7478341a06fce153f333410cd230f8266e6b0e4fb5e4247864710e3f572b6a837c99c2879d38899590f678
diff --git a/app-emacs/auctex/auctex-13.3.ebuild b/app-emacs/auctex/auctex-13.3.ebuild
new file mode 100644
index 000000000000..e89027a18640
--- /dev/null
+++ b/app-emacs/auctex/auctex-13.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Extensible package for writing and formatting TeX files in Emacs"
+HOMEPAGE="https://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="preview-latex"
+
+RDEPEND="
+ virtual/latex-base
+ preview-latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+TEXMF="/usr/share/texmf-site"
+
+src_configure() {
+ local -a myconf=(
+ --with-emacs
+ --with-auto-dir="${EPREFIX}/var/lib/auctex"
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}"
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}"
+ --with-texmf-dir="${EPREFIX}${TEXMF}"
+ --disable-build-dir-test
+ $(use_enable preview-latex preview)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ VARTEXFONTS="${T}/fonts" emake
+}
+
+src_install() {
+ emake -j1 DESTDIR="${ED}" install
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+
+ if use preview-latex ; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el"
+ fi
+
+ dodoc ChangeLog* CHANGES FAQ INSTALL PROBLEMS.preview README RELEASE TODO
+}
+
+pkg_postinst() {
+ use preview-latex && texmf-update
+
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ use preview-latex && texmf-update
+
+ elisp-site-regen
+}