summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/bongo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/bongo')
-rw-r--r--app-emacs/bongo/Manifest2
-rw-r--r--app-emacs/bongo/bongo-20110621.ebuild41
-rw-r--r--app-emacs/bongo/files/50bongo-gentoo.el4
-rw-r--r--app-emacs/bongo/files/bongo-20070619-fix-require.patch11
-rw-r--r--app-emacs/bongo/files/bongo-20110621-texinfo-5.patch12
-rw-r--r--app-emacs/bongo/metadata.xml33
6 files changed, 103 insertions, 0 deletions
diff --git a/app-emacs/bongo/Manifest b/app-emacs/bongo/Manifest
new file mode 100644
index 000000000000..4d678e697928
--- /dev/null
+++ b/app-emacs/bongo/Manifest
@@ -0,0 +1,2 @@
+DIST bongo-20110621.tar.xz 97652 SHA256 0fa7603d8239351725c6abe37ca8781a221821defb081c329620ed4dcc2a5cfe SHA512 31c2a477cfb5ff36fbc64da29c725db0b0242ea09f80883fb21feb3b23f5c14c688379c4c4e53b26ffef3aca5d2813d5b2a38b91266da088c73516f7ea1d712b WHIRLPOOL 29fa53b77626cf0c8dc79bbdea16912dbb12ddb8cdcd344f98ecef5c20e480566aa6792341739efd08a600a0c5ef09b0fdb7c679aaf520f66845af3ca83a7adb
+DIST bongo-mplayer-20070204.tar.bz2 3563 SHA256 a80aa2c3c6def4e679094817ca9db3c0766811f094766ee4b399eec93c062ec9 SHA512 e503ed7980f011a6fc3fa75d0bb9b1cec1ed49d4fb07da92aad65e3c5096b42cf9eb203a8edbb93f2e7924254e4926e9f3fcf473de877fea130557aefad73ebd WHIRLPOOL 86ed787b8fa4909cbb89f24d17b524cc4b5d7c8d5e1d0c4ecac5289967176c599df58abc91c643f70f0c40cfbee573101641d7c53db35cd7521664fa22eaa93e
diff --git a/app-emacs/bongo/bongo-20110621.ebuild b/app-emacs/bongo/bongo-20110621.ebuild
new file mode 100644
index 000000000000..c551acd945e5
--- /dev/null
+++ b/app-emacs/bongo/bongo-20110621.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp eutils
+
+DESCRIPTION="Buffer-oriented media player for Emacs"
+HOMEPAGE="http://www.brockman.se/software/bongo/"
+# Darcs snapshot of http://www.brockman.se/software/bongo/
+# MPlayer support from http://www.emacswiki.org/emacs/bongo-mplayer.el
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ mplayer? ( mirror://gentoo/${PN}-mplayer-20070204.tar.bz2 )"
+
+LICENSE="GPL-2+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mplayer"
+
+# NOTE: Bongo can use almost anything for playing media files, therefore
+# the dependency possibilities are so broad that we refrain from including
+# any media players explicitly in DEPEND/RDEPEND.
+
+RDEPEND="app-emacs/volume"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo"
+
+S="${WORKDIR}/${PN}"
+DOCS="AUTHORS HISTORY NEWS README.rdoc"
+ELISP_PATCHES="${PN}-20070619-fix-require.patch
+ ${P}-texinfo-5.patch"
+ELISP_REMOVE="bongo-emacs21.el" # Don't bother with Emacs 21
+ELISP_TEXINFO="${PN}.texinfo"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ insinto "${SITEETC}/${PN}"
+ doins etc/*.pbm etc/*.png
+}
diff --git a/app-emacs/bongo/files/50bongo-gentoo.el b/app-emacs/bongo/files/50bongo-gentoo.el
new file mode 100644
index 000000000000..099de2b3dd74
--- /dev/null
+++ b/app-emacs/bongo/files/50bongo-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(if (boundp 'image-load-path)
+ (add-to-list 'image-load-path "@SITEETC@" t))
+(autoload 'bongo "bongo" "Start Bongo by switching to a Bongo buffer." t)
diff --git a/app-emacs/bongo/files/bongo-20070619-fix-require.patch b/app-emacs/bongo/files/bongo-20070619-fix-require.patch
new file mode 100644
index 000000000000..6b3e6ff588df
--- /dev/null
+++ b/app-emacs/bongo/files/bongo-20070619-fix-require.patch
@@ -0,0 +1,11 @@
+--- bongo-orig/bongo.el 2007-06-19 16:51:37.000000000 +0200
++++ bongo/bongo.el 2008-06-22 15:30:23.000000000 +0200
+@@ -67,7 +67,7 @@
+
+ ;;; Code:
+
+-(eval-when-compile
++(eval-and-compile
+ (require 'cl)
+ (require 'rx))
+
diff --git a/app-emacs/bongo/files/bongo-20110621-texinfo-5.patch b/app-emacs/bongo/files/bongo-20110621-texinfo-5.patch
new file mode 100644
index 000000000000..3fa257b97f1c
--- /dev/null
+++ b/app-emacs/bongo/files/bongo-20110621-texinfo-5.patch
@@ -0,0 +1,12 @@
+--- bongo-orig/bongo.texinfo
++++ bongo/bongo.texinfo
+@@ -374,7 +374,8 @@
+
+ @item @kbd{C-u C-u C-u b}, @kbd{C-u C-u C-u f}
+ Seek 64 seconds.
+-@end table}.
++@end table
++}.
+ @end table
+
+ To seek a specific number of seconds, give a numeric prefix argument to
diff --git a/app-emacs/bongo/metadata.xml b/app-emacs/bongo/metadata.xml
new file mode 100644
index 000000000000..a65893303f93
--- /dev/null
+++ b/app-emacs/bongo/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Bongo is a buffer-oriented media player for Emacs, contemporary with and
+ comparable to <pkg>app-emacs/emms</pkg>.
+
+ Notable features of Bongo include
+ * separate playlist and library buffers (each of which you may have any
+ number — even zero of both is okay if you don’t need playlist
+ functionality),
+ * hierarchical buffers with collapsable sections for each artist and album,
+ * familiar Emacs bindings for editing Bongo buffers (edit playlists much
+ like you would regular text),
+ * a nice visual seeking interface doubling as a progress meter (hit ‘s’),
+ * a visual audio volume control (<pkg>app-emacs/volume</pkg>, which is
+ actually a stand-alone package),
+ * built-in support for playing and retrieving information about audio CDs,
+ * built-in support for submitting information to Last.fm using
+ ‘lastfmsubmitd’,
+ * the ability to perform arbitrary actions (stopping playback is a simple
+ example) once playback reaches certain points in the playlist, using
+ so-called “action tracks”,
+ * an XMMS-like keymap for XMMS refugees,
+ * zero-configuration, out-of-the-box rock’n’roll action.
+
+ Bongo currently comes with backends for VLC, mpg321, ogg123, speexdec,
+ TiMidity and MikMod. All backends support pausing and resuming, but only VLC
+ and mpg321 support interactive seeking. Defining your own non-interactive
+ backends is very simple.
+</longdescription>
+</pkgmetadata>