summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-12 00:59:40 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-12 00:59:40 +0200
commitd0ee20387be48b44da48fef46aa29baea52bbb13 (patch)
tree3cf9c785272048d18606cd7e7b4a0155034358e8 /app-emacs/cider
parentdev-dotnet/fantomas: drop old 6.3.8 (diff)
downloadgentoo-d0ee20387be48b44da48fef46aa29baea52bbb13.tar.gz
gentoo-d0ee20387be48b44da48fef46aa29baea52bbb13.tar.bz2
gentoo-d0ee20387be48b44da48fef46aa29baea52bbb13.zip
app-emacs/cider: bump to 1.15.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/cider')
-rw-r--r--app-emacs/cider/Manifest1
-rw-r--r--app-emacs/cider/cider-1.15.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-emacs/cider/Manifest b/app-emacs/cider/Manifest
index ec352cbb4b8a..b13ef6c4f474 100644
--- a/app-emacs/cider/Manifest
+++ b/app-emacs/cider/Manifest
@@ -1,2 +1,3 @@
DIST cider-1.13.1.tar.gz 7315314 BLAKE2B 81a0436ccb4a5e0d13e89587d55b4d63da3bca401ef95f995b20a58b8b0a1ed29b81df545135bccecfa601a33ccbad33478658afe612b179bbb3c38e5f6f60c4 SHA512 2d689f0e6bdcf778d86052c3d06e2e68e8ea37f4550979fb760ba57d1f0c6a9f3833d4c8ba265ddb641330cb22058abf095f87dd0bd93b40341c77be286ed5ad
DIST cider-1.14.0.tar.gz 7324413 BLAKE2B 6340b222e4cac6c9fb05d409380d766e497321e161a70cfdc29db78cc253cf39d4275ee9d8caaa825fe164fd251b2e64b76bf53bfea6671ea1b871ef91b31454 SHA512 b88b75547ee807e072a8e56471ce4a9c79a8c9a32c5c2fa0d5a4ad6527c94a0d409c3f5a89daa49024bcd0fb16f6bc8bbd3985cacc20cdba50e3675e7e995145
+DIST cider-1.15.0.tar.gz 7412812 BLAKE2B d5f386c9af524becc179d87a2da88d108fb7f7076b57a02080d84d22be00944b00f45def825cee60a813e328a399682bfed42b379561d26fa55a737a9cafa08c SHA512 c00ba3552c021e6c2d56d0f3e891c56d7492a99df3afe9f4eb17e473b365a110c0b918c9f90b0cbe87508125a806fe0dab47bc52bfc95cb07fd48960d7b049d6
diff --git a/app-emacs/cider/cider-1.15.0.ebuild b/app-emacs/cider/cider-1.15.0.ebuild
new file mode 100644
index 000000000000..ae265c008537
--- /dev/null
+++ b/app-emacs/cider/cider-1.15.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp optfeature
+
+DESCRIPTION="Clojure Interactive Development Environment for GNU Emacs"
+HOMEPAGE="https://cider.mx/
+ https://github.com/clojure-emacs/cider/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/clojure-emacs/${PN}.git"
+else
+ SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-emacs/clojure-mode
+ app-emacs/parseedn
+ app-emacs/queue
+ app-emacs/sesman
+ app-emacs/spinner
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/buttercup )
+"
+
+# The "clojure-ts-mode" is currently unpackaged, so remove related tests.
+ELISP_REMOVE="
+ test/${PN}-jar-tests.el
+ test/${PN}-repl-tests.el
+ test/clojure-ts-mode/${PN}-connection-ts-tests.el
+ test/clojure-ts-mode/${PN}-selector-ts-tests.el
+ test/clojure-ts-mode/${PN}-util-ts-tests.el
+ test/enrich/${PN}-docstring-tests.el
+ test/integration/integration-tests.el
+"
+DOCS=( CHANGELOG.md README.md ROADMAP.md refcard )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup test
+
+src_install() {
+ elisp_src_install
+
+ optfeature "Connecting to leiningen REPL" \
+ dev-java/leiningen dev-java/leiningen-bin
+}