summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/cmail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/cmail')
-rw-r--r--app-emacs/cmail/Manifest1
-rw-r--r--app-emacs/cmail/cmail-2.62-r1.ebuild50
-rw-r--r--app-emacs/cmail/files/70cmail-gentoo.el5
-rw-r--r--app-emacs/cmail/metadata.xml8
4 files changed, 64 insertions, 0 deletions
diff --git a/app-emacs/cmail/Manifest b/app-emacs/cmail/Manifest
new file mode 100644
index 000000000000..4cfde9483c5a
--- /dev/null
+++ b/app-emacs/cmail/Manifest
@@ -0,0 +1 @@
+DIST cmail-2.62.tar.gz 507137 SHA256 b59c19fe9e8ecb0269960691916f5328f8fa133363808a59ece125fc7bf65668 SHA512 0b042861b6975910f281e949592bce7d83f94f6f5c78690ad7a4ecd4267b57c1e84fda0746d3018194d4e6d1a3c84a5a4c7fa172ec25027a957ad8400aff17b8 WHIRLPOOL 3611265181dbf9b4c5157c171f1f69ef59dec6f166f674c7ea75dbc6c5dbcbd3eabb39b445b6e2f4e7c23fdb22b763482bb0b3d011248e4d803dedc95227f519
diff --git a/app-emacs/cmail/cmail-2.62-r1.ebuild b/app-emacs/cmail/cmail-2.62-r1.ebuild
new file mode 100644
index 000000000000..f0e62c584cc0
--- /dev/null
+++ b/app-emacs/cmail/cmail-2.62-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit elisp
+
+DESCRIPTION="A simple mail management system for Emacs"
+HOMEPAGE="http://cmail.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/2191/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="linguas_ja"
+
+RDEPEND="app-emacs/apel
+ virtual/emacs-flim
+ app-emacs/semi"
+
+SITEFILE="70cmail-gentoo.el"
+
+src_compile() {
+ emake EMACS="${EMACS}" FLAGS="${EMACSFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake EMACS="${EMACS}" \
+ FLAGS="${EMACSFLAGS} \
+ --eval \"(setq CMAIL_ICON_DIR \\\"${D}${SITEETC}/${PN}/icon\\\")\"" \
+ PREFIX="${D}/usr" \
+ LISPDIR="${D}/${SITELISP}" \
+ INFODIR="${D}/usr/share/info" \
+ VERSION_SPECIFIC_LISPDIR="${D}/${SITELISP}" install \
+ || die "emake install failed"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ dodoc ChangeLog INTRO.en README.en sample.* \
+ doc/README.{POP,gnuspop3}.en doc/cmail-r2c.en.doc || die "dodoc failed"
+
+ if use linguas_ja; then
+ dodoc README.ja RELNOTES.ja doc/FAQ \
+ doc/README.{FETCHMAIL,POP,bbdb,cmail-crypt,cvs-access} \
+ doc/README.{feedmail,folders,gnuspop3,imap4} \
+ doc/README.{multi-account,multi-highlight,nickname} \
+ doc/cmail-r2c.doc doc/glossary || die "dodoc failed"
+ else
+ rm -f "${D}"/usr/share/info/cmail.info*
+ fi
+}
diff --git a/app-emacs/cmail/files/70cmail-gentoo.el b/app-emacs/cmail/files/70cmail-gentoo.el
new file mode 100644
index 000000000000..5bc1fbb3711d
--- /dev/null
+++ b/app-emacs/cmail/files/70cmail-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; cmail site-lisp configuration
+
+(setq cmail-spool-directory "/var/spool/mail")
+(autoload 'cmail "cmail" nil t)
diff --git a/app-emacs/cmail/metadata.xml b/app-emacs/cmail/metadata.xml
new file mode 100644
index 000000000000..955ea9e4689e
--- /dev/null
+++ b/app-emacs/cmail/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="sourceforge-jp">cmail</remote-id>
+</upstream>
+</pkgmetadata>