summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-17 13:05:45 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-17 15:18:49 +0200
commitb08072005d86445b5992ede577194c892974b03a (patch)
tree07a2cc6cd442ad80e74ff3c71a21506bd408b129 /app-emacs/expand-region
parentapp-emacs/buffer-extension: Update metadata. (diff)
downloadgentoo-b08072005d86445b5992ede577194c892974b03a.tar.gz
gentoo-b08072005d86445b5992ede577194c892974b03a.tar.bz2
gentoo-b08072005d86445b5992ede577194c892974b03a.zip
app-emacs/expand-region: Inline autoloads.
Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/expand-region')
-rw-r--r--app-emacs/expand-region/expand-region-0.11.0-r1.ebuild (renamed from app-emacs/expand-region/expand-region-0.11.0.ebuild)15
-rw-r--r--app-emacs/expand-region/files/50expand-region-gentoo.el3
2 files changed, 7 insertions, 11 deletions
diff --git a/app-emacs/expand-region/expand-region-0.11.0.ebuild b/app-emacs/expand-region/expand-region-0.11.0-r1.ebuild
index b151534d2ef7..520e27025faf 100644
--- a/app-emacs/expand-region/expand-region-0.11.0.ebuild
+++ b/app-emacs/expand-region/expand-region-0.11.0-r1.ebuild
@@ -1,23 +1,18 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit elisp
DESCRIPTION="Emacs extension to increase selected region by semantic units"
HOMEPAGE="https://github.com/magnars/expand-region.el"
-SRC_URI="https://github.com/magnars/expand-region.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/magnars/${PN}.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
-S="${WORKDIR}/expand-region.el-${PV}"
+S="${WORKDIR}/${PN}.el-${PV}"
SITEFILE="50${PN}-gentoo.el"
DOCS="README.md"
-
-src_compile() {
- elisp-compile *.el
- elisp-make-autoload-file
-}
diff --git a/app-emacs/expand-region/files/50expand-region-gentoo.el b/app-emacs/expand-region/files/50expand-region-gentoo.el
index bd5b40540780..4b065061de9e 100644
--- a/app-emacs/expand-region/files/50expand-region-gentoo.el
+++ b/app-emacs/expand-region/files/50expand-region-gentoo.el
@@ -1,2 +1,3 @@
(add-to-list 'load-path "@SITELISP@")
-(load "expand-region-autoloads" nil t)
+(autoload 'er/expand-region "expand-region"
+ "Increase selected region by semantic units." t)