summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-08-27 11:37:55 +0200
committerUlrich Müller <ulm@gentoo.org>2019-08-27 11:37:55 +0200
commit74839c947e017c19aa8d98add919c7a482678d12 (patch)
treecf9997f783cf6f182316a870a4f6dbb1bdf23a89 /app-emacs/mldonkey
parentapp-emacs/elscreen: Fix typo in longdescription. (diff)
downloadgentoo-74839c947e017c19aa8d98add919c7a482678d12.tar.gz
gentoo-74839c947e017c19aa8d98add919c7a482678d12.tar.bz2
gentoo-74839c947e017c19aa8d98add919c7a482678d12.zip
app-emacs/mldonkey: Bump EAPI to 7.
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/mldonkey')
-rw-r--r--app-emacs/mldonkey/mldonkey-0.0.4b-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/mldonkey/mldonkey-0.0.4b-r2.ebuild b/app-emacs/mldonkey/mldonkey-0.0.4b-r2.ebuild
new file mode 100644
index 000000000000..b5714cc69480
--- /dev/null
+++ b/app-emacs/mldonkey/mldonkey-0.0.4b-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp readme.gentoo-r1
+
+MY_P="${PN}-el-${PV}"
+DESCRIPTION="An Emacs Lisp interface to the MLDonkey core"
+HOMEPAGE="https://www.emacswiki.org/emacs/MlDonkey
+ http://web.archive.org/web/20070107165326/www.physik.fu-berlin.de/~dhansen/mldonkey/"
+SRC_URI="http://www.physik.fu-berlin.de/%7Edhansen/mldonkey/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${MY_P}"
+ELISP_PATCHES="${P}-vd.patch ${P}-emacs-26.patch"
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="If your network gets really slow when you use mldonkey,
+ consider reducing the max number of connections. See bug #50510.
+ \n\nRemember to install net-p2p/mldonkey separately if you want to
+ work with a local instance."
+
+src_compile() {
+ elisp-compile ml*.el
+}