summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-03 01:37:27 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-03 01:48:49 +0200
commit1e8f7fcb72ce9d9a39b45cb6e741e5b40a7e3272 (patch)
treea5bc573139af85b7063a09d122dcd1a3d4ea7b8e /app-emacs/osm
parentapp-emacs/osm: drop old 0.11 (diff)
downloadgentoo-1e8f7fcb72ce9d9a39b45cb6e741e5b40a7e3272.tar.gz
gentoo-1e8f7fcb72ce9d9a39b45cb6e741e5b40a7e3272.tar.bz2
gentoo-1e8f7fcb72ce9d9a39b45cb6e741e5b40a7e3272.zip
app-emacs/osm: bump to 0.13
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/osm')
-rw-r--r--app-emacs/osm/Manifest1
-rw-r--r--app-emacs/osm/osm-0.13.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/osm/Manifest b/app-emacs/osm/Manifest
index 28692194e17c..000436bfe897 100644
--- a/app-emacs/osm/Manifest
+++ b/app-emacs/osm/Manifest
@@ -1 +1,2 @@
DIST osm-0.12.tar.gz 32029 BLAKE2B 42a8f70acb01ac0b326ac0e345528f2181e5ab45a92bfcc796d2d8cab5b587e4b071c5d1235cc92f4362be3849cd454015de096314b2de0ebd02bdc631588e03 SHA512 ad21fe39c096250f8e5249ae67c399ccb976a48576ced9e9ed4accbd7cbeed4a30e3c347ca5b4ba2f8e2b7db5a161b3145b01121860b9ee3880d06241bec3edc
+DIST osm-0.13.tar.gz 32400 BLAKE2B 0b97d1adb67510f393dc13b8f314e8b8cc089d1b5d4e440331a2c8ddf42799c5e04b6448eb35d3acd55c8fc363f82415d8b8cdf83e06fa3ccccceaa07ffd68e4 SHA512 4313ccb42c6c7a7fc582d5f2a476ff09890306c82bf0554654443906e593509692450d0db4b6ef4fde906aa750d925bd3156e74d8fcf6f780eb37a3761aa20e6
diff --git a/app-emacs/osm/osm-0.13.ebuild b/app-emacs/osm/osm-0.13.ebuild
new file mode 100644
index 000000000000..e10c84ef5e7f
--- /dev/null
+++ b/app-emacs/osm/osm-0.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="OpenStreetMap tile-based viewer for GNU Emacs"
+HOMEPAGE="https://github.com/minad/osm/"
+SRC_URI="https://github.com/minad/osm/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=app-editors/emacs-${NEED_EMACS}:*[jpeg,json,libxml2,png,svg]
+ >=app-emacs/compat-29.1.4.0
+"
+RDEPEND="
+ ${BDEPEND}
+ net-misc/curl[ssl]
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}