summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-14 12:14:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-14 12:15:20 +0200
commit2d8b4a9094ef18a0b179c487e45bced3f8565d6c (patch)
tree83e4c925e147cac4203b839813564acbac7fe404 /app-emacs/pandoc-mode/pandoc-mode-2.32-r1.ebuild
parentapp-editors/emacs: Drop seccomp USE flag (diff)
downloadgentoo-2d8b4a9094ef18a0b179c487e45bced3f8565d6c.tar.gz
gentoo-2d8b4a9094ef18a0b179c487e45bced3f8565d6c.tar.bz2
gentoo-2d8b4a9094ef18a0b179c487e45bced3f8565d6c.zip
app-emacs/pandoc-mode: remove Emacs version limit
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/pandoc-mode/pandoc-mode-2.32-r1.ebuild')
-rw-r--r--app-emacs/pandoc-mode/pandoc-mode-2.32-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/pandoc-mode/pandoc-mode-2.32-r1.ebuild b/app-emacs/pandoc-mode/pandoc-mode-2.32-r1.ebuild
new file mode 100644
index 000000000000..4d7d1760c9a9
--- /dev/null
+++ b/app-emacs/pandoc-mode/pandoc-mode-2.32-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="BibTeX database manager for Emacs"
+HOMEPAGE="https://joostkremers.github.io/pandoc-mode/
+ https://github.com/joostkremers/pandoc-mode/"
+SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64"
+SLOT="0"
+
+BDEPEND="
+ app-emacs/dash
+ app-emacs/hydra
+"
+RDEPEND="
+ ${BDEPEND}
+ virtual/pandoc
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ doinfo ${PN}.info
+}