summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-26 17:29:38 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-26 17:46:10 +0200
commit7d0498921edf247868295d5b2c35f8a484e1af19 (patch)
tree2ed1c70f8c2611b81f351c38c1fc7b62613e3bb9 /app-emacs/transient/transient-0.4.3.ebuild
parentdev-lang/luau: bump to 0.592 (diff)
downloadgentoo-7d0498921edf247868295d5b2c35f8a484e1af19.tar.gz
gentoo-7d0498921edf247868295d5b2c35f8a484e1af19.tar.bz2
gentoo-7d0498921edf247868295d5b2c35f8a484e1af19.zip
app-emacs/transient: bump to 0.4.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/transient/transient-0.4.3.ebuild')
-rw-r--r--app-emacs/transient/transient-0.4.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/transient/transient-0.4.3.ebuild b/app-emacs/transient/transient-0.4.3.ebuild
new file mode 100644
index 000000000000..8fae47219ad7
--- /dev/null
+++ b/app-emacs/transient/transient-0.4.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org docs/${PN}.org )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND=">=app-emacs/compat-29.1.4.1"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}