summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-05 23:37:04 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-05 23:44:18 +0200
commite2e0fae507844e22f46cea7ef16ab1690cb10efc (patch)
tree7e058da8f2d10483fe3cd9dddd4d7e19d15ceb05 /app-emacs/transient
parentapp-emacs/no-littering: bump to 1.7.3 (diff)
downloadgentoo-e2e0fae507844e22f46cea7ef16ab1690cb10efc.tar.gz
gentoo-e2e0fae507844e22f46cea7ef16ab1690cb10efc.tar.bz2
gentoo-e2e0fae507844e22f46cea7ef16ab1690cb10efc.zip
app-emacs/transient: bump to 0.7.7
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/transient')
-rw-r--r--app-emacs/transient/Manifest1
-rw-r--r--app-emacs/transient/transient-0.7.7.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/transient/Manifest b/app-emacs/transient/Manifest
index 819299d8b76f..95a00020b5cb 100644
--- a/app-emacs/transient/Manifest
+++ b/app-emacs/transient/Manifest
@@ -1,2 +1,3 @@
DIST transient-0.7.5.tar.gz 141189 BLAKE2B 55535f6121467a1f380ec8d6a4afbb810556f914dc30a7c2fb913f2238bd47809f3d8aadfe35cfdae087525048e83beb14380cd3fdf6cae59643191147df4789 SHA512 18d051235b15e95312fcd60ddfa0f0ba85351d6102117717c81f621528a46a6d0f03d918002a7af2702135ebcf53c498f079a12d99ffc68711e20b196045e032
DIST transient-0.7.6.tar.gz 141843 BLAKE2B 30ef7aaa1c90a66ab377f076c6a75f217ae1bf40d9541558c0a21a258a53d3c980d7d305658d644e345fcafd3fe6722054ec6154616c6f9dd917a94c70f93fa4 SHA512 315af2dd6f9503f1f695dcb85c8a157651c1b0df4d5272d6a16c0e579213c475a4637db8f262016ef4a99a532c7b5d8c1c9a4ac456ac6deb7d711c6490af2b11
+DIST transient-0.7.7.tar.gz 141990 BLAKE2B 3462a46958e8865753e9bc9d5c1942141068853551a82857d8009214a52a6df67164199d9f8d942f32c6e77029d8ec5932e0d6ec04acc7c97576c3074d4f75d1 SHA512 b908a69e7cb1c3e0987be4bf427361b414c068e8dc8bf025403e775190156011ee3870ad2272cf90c2d2006553a6f2ee7107f267ff6aa0b0af9cf61bd697e15e
diff --git a/app-emacs/transient/transient-0.7.7.ebuild b/app-emacs/transient/transient-0.7.7.ebuild
new file mode 100644
index 000000000000..f99ae40b0465
--- /dev/null
+++ b/app-emacs/transient/transient-0.7.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org "docs/${PN}.org" )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ elisp_src_prepare
+}