summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-10 13:22:01 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-10 17:35:30 +0200
commit5b3f293997b8cb7cf3d405770b9a02621dea7042 (patch)
tree56f3a3a4e62cbb5253edab59e694c1c44fa4d24a /app-emacs
parentapp-text/pandoc-bin: bump to 3.1.8 (diff)
downloadgentoo-5b3f293997b8cb7cf3d405770b9a02621dea7042.tar.gz
gentoo-5b3f293997b8cb7cf3d405770b9a02621dea7042.tar.bz2
gentoo-5b3f293997b8cb7cf3d405770b9a02621dea7042.zip
app-emacs/nerd-icons: new package; add 0.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/nerd-icons/Manifest1
-rw-r--r--app-emacs/nerd-icons/files/50nerd-icons-gentoo.el2
-rw-r--r--app-emacs/nerd-icons/metadata.xml13
-rw-r--r--app-emacs/nerd-icons/nerd-icons-0.1.0.ebuild60
4 files changed, 76 insertions, 0 deletions
diff --git a/app-emacs/nerd-icons/Manifest b/app-emacs/nerd-icons/Manifest
new file mode 100644
index 000000000000..5542250732ed
--- /dev/null
+++ b/app-emacs/nerd-icons/Manifest
@@ -0,0 +1 @@
+DIST nerd-icons-0.1.0.tar.gz 1485030 BLAKE2B f70411118071cc360d6c335e7276cc27839c35fa35a015540649d9cc2624e1e32f2bac10a4afef40f0fb6cb4a7063919b4fd8f02d73941d7c055be999164340c SHA512 7d7e03f4aa85f8b16cf0eb5c272f22bbecbf54f51a5d52dfadc509743e5bf02397de5ca9f2946bb6cbdadd5aa4dc105b1245e7b86f8589211aff354f03b7aa0a
diff --git a/app-emacs/nerd-icons/files/50nerd-icons-gentoo.el b/app-emacs/nerd-icons/files/50nerd-icons-gentoo.el
new file mode 100644
index 000000000000..c8a2fe789c48
--- /dev/null
+++ b/app-emacs/nerd-icons/files/50nerd-icons-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "nerd-icons-autoloads" nil t)
diff --git a/app-emacs/nerd-icons/metadata.xml b/app-emacs/nerd-icons/metadata.xml
new file mode 100644
index 000000000000..b127ea8dc2c5
--- /dev/null
+++ b/app-emacs/nerd-icons/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/rainstormstudio/nerd-icons.el/issues/</bugs-to>
+ <remote-id type="github">rainstormstudio/nerd-icons.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/nerd-icons/nerd-icons-0.1.0.ebuild b/app-emacs/nerd-icons/nerd-icons-0.1.0.ebuild
new file mode 100644
index 000000000000..1a235f3d93d0
--- /dev/null
+++ b/app-emacs/nerd-icons/nerd-icons-0.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp font readme.gentoo-r1
+
+DESCRIPTION="Emacs Nerd Font Icons Library"
+HOMEPAGE="https://github.com/rainstormstudio/nerd-icons.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rainstormstudio/${PN}.el.git"
+else
+ SRC_URI="https://github.com/rainstormstudio/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}.el-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+FONT_PN="NFM"
+FONT_S="${S}/fonts"
+FONT_SUFFIX="ttf"
+
+DOC_CONTENTS="You may need to install the required fonts by executing
+ the \"nerd-icons-install-fonts\" function."
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_setup() {
+ elisp_pkg_setup
+ font_pkg_setup
+}
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+ elisp-compile data/*.el
+}
+
+src_install() {
+ elisp_src_install
+ font_src_install
+
+ elisp-install "${PN}/data" data/*.el{,c}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ font_pkg_postinst
+}
+
+pkg_postrm() {
+ elisp_pkg_postrm
+ font_pkg_postrm
+}