summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-20 10:26:38 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-20 12:31:18 +0100
commit6312212f139d988eb4688378dcbd0b0934d05f5e (patch)
treea54c40946e4f8148cf500292553be54addcffa7d /app-emacs
parentapp-emacs/parsebib: bump to 6.3 (diff)
downloadgentoo-6312212f139d988eb4688378dcbd0b0934d05f5e.tar.gz
gentoo-6312212f139d988eb4688378dcbd0b0934d05f5e.tar.bz2
gentoo-6312212f139d988eb4688378dcbd0b0934d05f5e.zip
app-emacs/php-mode: bump to 1.27.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/php-mode/Manifest1
-rw-r--r--app-emacs/php-mode/php-mode-1.27.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/php-mode/Manifest b/app-emacs/php-mode/Manifest
index 6e52681121f5..d8e4114bc3d9 100644
--- a/app-emacs/php-mode/Manifest
+++ b/app-emacs/php-mode/Manifest
@@ -1 +1,2 @@
DIST php-mode-1.26.1.tar.gz 132347 BLAKE2B aa860304e8772e7b4f0eda98711acb1fced279fda16fe491477deaf47e79ef4a841686906783633a7eedd2d19e1569bd1fb17b693588f1b950ee8a7e540e9c77 SHA512 85e9049f895fbba17cab4ef868336aa992821b3dd4167a2c9e1c8ef748bd9d3ac6a413a125391374552beb02dd2a3a6263bd739da78691361e0500c4e0ed29c8
+DIST php-mode-1.27.0.gh.tar.gz 133871 BLAKE2B e326ef5b2fd4a62d815df30312b59470d1576284585db5266c351c18c898f801643ed3529ab5b66972b91f43c61a92da552e9f15b60d4c254e0b936c7bc60d9c SHA512 61ac62168e5ccc1076e6395b549e2401cb2f01309303d7553c84497ef245fb14400c6bf9e961fa3c6a38afc1b1125663d01b659846799d8371c873b6f46c691e
diff --git a/app-emacs/php-mode/php-mode-1.27.0.ebuild b/app-emacs/php-mode/php-mode-1.27.0.ebuild
new file mode 100644
index 000000000000..89fab89e4c5e
--- /dev/null
+++ b/app-emacs/php-mode/php-mode-1.27.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for editing PHP code"
+HOMEPAGE="https://github.com/emacs-php/php-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-php/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-php/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../AUTHORS.md ../CHANGELOG.md ../CONTRIBUTING.md ../README{,.ja}.md ../docs )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert "${S}" -L ../tests -l ../tests/php-mode-test.el
+
+src_test() {
+ touch ../tests/project/1/.git || die
+
+ elisp_src_test
+}