summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-14 11:53:52 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-14 12:05:27 +0200
commit9a0a581ce775d9070f40f559a5aa466593e5a396 (patch)
tree41e3b65301b1ffb58a2b418363f8093acce8a098 /app-emacs
parentsci-mathematics/lean: drop old 3.42.1 (diff)
downloadgentoo-9a0a581ce775d9070f40f559a5aa466593e5a396.tar.gz
gentoo-9a0a581ce775d9070f40f559a5aa466593e5a396.tar.bz2
gentoo-9a0a581ce775d9070f40f559a5aa466593e5a396.zip
app-emacs/pandoc-mode: new package; add version 2.32
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/pandoc-mode/Manifest1
-rw-r--r--app-emacs/pandoc-mode/files/50pandoc-mode-gentoo.el5
-rw-r--r--app-emacs/pandoc-mode/metadata.xml20
-rw-r--r--app-emacs/pandoc-mode/pandoc-mode-2.32.ebuild35
4 files changed, 61 insertions, 0 deletions
diff --git a/app-emacs/pandoc-mode/Manifest b/app-emacs/pandoc-mode/Manifest
new file mode 100644
index 000000000000..e3e76e674447
--- /dev/null
+++ b/app-emacs/pandoc-mode/Manifest
@@ -0,0 +1 @@
+DIST pandoc-mode-2.32.tar.gz 97596 BLAKE2B 2a1c8a6080fbba1cf278d78f9dbe4e6824daed52ad6422378d6b5c00fd4ec9466391474fdbaad5f1cd96d89080c24968b33c0911cb5f834ddd64dc1339b78c01 SHA512 6717bf238a9f71acce8135d5fa0542c23f2b48d78415f92dda2ef58aa0355ca0fe900e1015d0da674abf7780ed614bd7d4414519bf6d0d7f5aee7e3b7a7f447f
diff --git a/app-emacs/pandoc-mode/files/50pandoc-mode-gentoo.el b/app-emacs/pandoc-mode/files/50pandoc-mode-gentoo.el
new file mode 100644
index 000000000000..7b5175907861
--- /dev/null
+++ b/app-emacs/pandoc-mode/files/50pandoc-mode-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'conditionally-turn-on-pandoc "pandoc-mode"
+ "Turn on pandoc-mode if a pandoc settings file exists.") ; non-interactive
+(autoload 'pandoc-mode "pandoc-mode"
+ "Minor mode for interacting with Pandoc." t)
diff --git a/app-emacs/pandoc-mode/metadata.xml b/app-emacs/pandoc-mode/metadata.xml
new file mode 100644
index 000000000000..2836a8a3bb27
--- /dev/null
+++ b/app-emacs/pandoc-mode/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ pandoc-mode is an Emacs mode for interacting with Pandoc. pandoc-mode is
+ implemented as a minor mode that can be activated alongside the major mode
+ for any of Pandoc's supported input formats. It provides facilities to set
+ the various options that Pandoc accepts and to run Pandoc on the input
+ file.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/joostkremers/pandoc-mode/issues/</bugs-to>
+ <remote-id type="github">joostkremers/pandoc-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/pandoc-mode/pandoc-mode-2.32.ebuild b/app-emacs/pandoc-mode/pandoc-mode-2.32.ebuild
new file mode 100644
index 000000000000..3469a1a55d59
--- /dev/null
+++ b/app-emacs/pandoc-mode/pandoc-mode-2.32.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="BibTeX database manager for Emacs"
+HOMEPAGE="https://joostkremers.github.io/pandoc-mode/
+ https://github.com/joostkremers/pandoc-mode/"
+SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64"
+SLOT="0"
+
+BDEPEND="
+ app-emacs/dash
+ app-emacs/hydra
+"
+RDEPEND="
+ ${BDEPEND}
+ virtual/pandoc
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ doinfo ${PN}.info
+}