summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-03 16:52:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-03 20:44:28 +0200
commitae828a852bd66817d432716e686ee1dc31698acb (patch)
tree879c7245254cb7dc58b1293d705559198e1f1d0b /app-emacs
parentapp-emacs/helm: bump to 4.0 (diff)
downloadgentoo-ae828a852bd66817d432716e686ee1dc31698acb.tar.gz
gentoo-ae828a852bd66817d432716e686ee1dc31698acb.tar.bz2
gentoo-ae828a852bd66817d432716e686ee1dc31698acb.zip
app-emacs/magit: bump to 4.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/magit/Manifest1
-rw-r--r--app-emacs/magit/magit-4.1.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/magit/Manifest b/app-emacs/magit/Manifest
index 93f7dc3e5b0e..203825827f89 100644
--- a/app-emacs/magit/Manifest
+++ b/app-emacs/magit/Manifest
@@ -1,2 +1,3 @@
DIST magit-3.3.0.50_p20240520.tar.gz 673945 BLAKE2B d61fb8c566de2bc6a2c4109d787808be76fa33d994adeb97b3d472c9c2da929aa55cf6b81f9cc2055e46d5860aa0d9ddc37080a1b2be06984b3831382031b12b SHA512 53203cdc8bc291302ee35aabe6e4d32e0c0de5bb411ab013d112bcd3d934a221c34f42d6ebccea9d33335d53415f75588468c23668cbbf57851dc61de505fffb
DIST magit-4.0.0.tar.gz 676167 BLAKE2B 2adc7388cddc5230615344b3340ae181feaea1e6c174970e11a5d6f6795ecb32581dc12448c1bdfa6ec4144cc4118ace70049ff264a2c29f084cf90aa3f56d69 SHA512 c42dfe78f1f1c5f6cc732a566b820362993763ada7186d1a76ba0deedf7bd91415d502984e4afd6e958ea237b3f351c718a9e588f9734d7afc186793432229f0
+DIST magit-4.1.0.tar.gz 673317 BLAKE2B 6457c77f08605e3665b3fadcb4d6bc48d21498e370261d9709305e774de579be4647afb6e598a446a3ddf06e47baef6561a48706609812991a24e3ab2b22d416 SHA512 063c23a7f1a9099d7ec020980be936b30b85756b30bded48264939c5ae7f742820efc3eadc8ba480ad328ca7276a9d35bb168e6b7a42ea8dfa6a2c1e13b8cc90
diff --git a/app-emacs/magit/magit-4.1.0.ebuild b/app-emacs/magit/magit-4.1.0.ebuild
new file mode 100644
index 000000000000..19d51447f288
--- /dev/null
+++ b/app-emacs/magit/magit-4.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/
+ https://github.com/magit/magit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../README.md ../docs/AUTHORS.md ../docs/RelNotes )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ >=app-emacs/dash-2.19.1
+ >=app-emacs/transient-0.7.4
+ >=app-emacs/with-editor-3.4.1
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+RDEPEND+="
+ >=dev-vcs/git-2.44.2
+"
+
+src_prepare() {
+ default
+
+ echo "(setq ${PN}-version \"${PV}\")" > ./${PN}-version.el || die
+}