summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2016-11-24 12:13:42 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2016-11-24 12:13:42 +0100
commitf4f82b34b1622ae8eb575ac97924fe773ce1a022 (patch)
tree36168802e243fd2c9d027d5d2aa6f8b6122da2ed /app-emulation/free42/files
parentnet-news/rssguard: remove old (diff)
downloadgentoo-f4f82b34b1622ae8eb575ac97924fe773ce1a022.tar.gz
gentoo-f4f82b34b1622ae8eb575ac97924fe773ce1a022.tar.bz2
gentoo-f4f82b34b1622ae8eb575ac97924fe773ce1a022.zip
app-emulation/free42: Bumps version to 1.5.12
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-emulation/free42/files')
-rw-r--r--app-emulation/free42/files/free42-1.5.12-fix-build-intel-lib.patch12
-rw-r--r--app-emulation/free42/files/free42-1.5.12-fix-makefile.patch38
2 files changed, 50 insertions, 0 deletions
diff --git a/app-emulation/free42/files/free42-1.5.12-fix-build-intel-lib.patch b/app-emulation/free42/files/free42-1.5.12-fix-build-intel-lib.patch
new file mode 100644
index 000000000000..23641b552f27
--- /dev/null
+++ b/app-emulation/free42/files/free42-1.5.12-fix-build-intel-lib.patch
@@ -0,0 +1,12 @@
+diff -Nuar a/gtk/build-intel-lib.sh b/gtk/build-intel-lib.sh
+--- a/gtk/build-intel-lib.sh 2016-09-04 18:56:12.000000000 +0200
++++ b/gtk/build-intel-lib.sh 2016-09-24 19:39:49.284126118 +0200
+@@ -4,7 +4,7 @@
+ cd IntelRDFPMathLib20U1
+ patch -p0 <../intel-lib-linux.patch
+ cd LIBRARY
+-make CC=gcc CALL_BY_REF=1 GLOBAL_RND=1 GLOBAL_FLAGS=1 UNCHANGED_BINARY_FLAGS=0
++make A=a CC=gcc CALL_BY_REF=1 GLOBAL_RND=1 GLOBAL_FLAGS=1 UNCHANGED_BINARY_FLAGS=0
+ mv libbid.a ../../gcc111libbid.a
+ cd ../..
+ ( echo '#ifdef FREE42_FPTEST'; echo 'const char *readtest_lines[] = {'; tr -d '\r' < IntelRDFPMathLib20U1/TESTS/readtest.in | sed 's/^\(.*\)$/"\1",/'; echo '0 };'; echo '#endif' ) > readtest_lines.cc
diff --git a/app-emulation/free42/files/free42-1.5.12-fix-makefile.patch b/app-emulation/free42/files/free42-1.5.12-fix-makefile.patch
new file mode 100644
index 000000000000..3fe1baf1b487
--- /dev/null
+++ b/app-emulation/free42/files/free42-1.5.12-fix-makefile.patch
@@ -0,0 +1,38 @@
+diff -Nuar a/gtk/Makefile b/gtk/Makefile
+--- a/gtk/Makefile 2016-09-04 18:56:12.000000000 +0200
++++ b/gtk/Makefile 2016-09-24 16:13:34.824116365 +0200
+@@ -15,11 +15,10 @@
+ # along with this program; if not, see http://www.gnu.org/licenses/.
+ ###############################################################################
+
+-CFLAGS = -MMD \
++CFLAGS := -MMD \
+ -Wall \
+ -Wno-parentheses \
+ -Wno-write-strings \
+- -g \
+ -I/usr/X11R6/include \
+ $(shell pkg-config --cflags gtk+-2.0) \
+ -DVERSION="\"$(shell cat ../VERSION)\"" \
+@@ -27,14 +26,16 @@
+ -DDECIMAL_GLOBAL_ROUNDING=1 \
+ -DDECIMAL_GLOBAL_ROUNDING_ACCESS_FUNCTIONS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS=1 \
+- -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1
++ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1 \
++ ${CFLAGS}
+
+-CXXFLAGS = $(CFLAGS) \
++CXXFLAGS := $(CFLAGS) \
+ -fno-exceptions \
+ -fno-rtti \
+- -D_WCHAR_T_DEFINED
++ -D_WCHAR_T_DEFINED \
++ ${CXXFLAGS}
+
+-LDFLAGS = -L/usr/X11R6/lib
++LDFLAGS := -L/usr/X11R6/lib ${LDFLAGS}
+-LIBS = gcc111libbid.a -lXmu $(shell pkg-config --libs gtk+-2.0)
++LIBS = gcc111libbid.a -lX11 -ldl -lXmu $(shell pkg-config --libs gtk+-2.0)
+
+ ifeq "$(shell uname -s)" "Linux"