summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-09-11 13:43:30 -0500
committerWilliam Hubbs <williamh@gentoo.org>2017-09-11 13:44:13 -0500
commitd5e5778f271ae34850281b9011729d7c9a015e6c (patch)
tree073a1337a4eeeec9f95c5470db3c273b32599d10 /app-emulation/go-secbench/go-secbench-0.1.0.ebuild
parentwww-client/opera: Remove USE=kde (bug #630662). (diff)
downloadgentoo-d5e5778f271ae34850281b9011729d7c9a015e6c.tar.gz
gentoo-d5e5778f271ae34850281b9011729d7c9a015e6c.tar.bz2
gentoo-d5e5778f271ae34850281b9011729d7c9a015e6c.zip
app-emulation/go-secbench: new package
This tool runs and parses the output of the docker-bench-security tool to make it more readable. Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-emulation/go-secbench/go-secbench-0.1.0.ebuild')
-rw-r--r--app-emulation/go-secbench/go-secbench-0.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emulation/go-secbench/go-secbench-0.1.0.ebuild b/app-emulation/go-secbench/go-secbench-0.1.0.ebuild
new file mode 100644
index 000000000000..fdceccf32659
--- /dev/null
+++ b/app-emulation/go-secbench/go-secbench-0.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/qnib/go-secbench"
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="run and evaluate the docker security benchmark"
+HOMEPAGE="https://github.com/qnib/go-secbench"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND="dev-lang/go"
+
+src_compile() {
+ GOPATH="${S}" go build -o bin/go-secbench src/${EGO_PN}/cmd/main.go || die
+}
+
+src_install() {
+ dobin bin/${PN}
+dodoc "src/${EGO_PN}/README.md"
+}