summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2018-08-14 17:12:25 +0200
committerTiziano Müller <dev-zero@gentoo.org>2018-08-14 17:14:48 +0200
commitbc51b968eb58887c91e46184734f98a6ac2c4cce (patch)
tree522a92656db77e69b33cab04d5c63b747994f5ec /app-emulation/libcacard/libcacard-2.6.0.ebuild
parentapp-emulation/libcacard: remove myself as maintainer (diff)
downloadgentoo-bc51b968eb58887c91e46184734f98a6ac2c4cce.tar.gz
gentoo-bc51b968eb58887c91e46184734f98a6ac2c4cce.tar.bz2
gentoo-bc51b968eb58887c91e46184734f98a6ac2c4cce.zip
app-emulation/libcacard: version bump for #611348
adding a new (default-on) USE flag to reduce deps for people wanting virtual certificate-based smartcards only Bug: https://bugs.gentoo.org/611348 Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'app-emulation/libcacard/libcacard-2.6.0.ebuild')
-rw-r--r--app-emulation/libcacard/libcacard-2.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/libcacard/libcacard-2.6.0.ebuild b/app-emulation/libcacard/libcacard-2.6.0.ebuild
new file mode 100644
index 000000000000..e54815fe8095
--- /dev/null
+++ b/app-emulation/libcacard/libcacard-2.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="virtual Common Access Card (CAC) library emulator"
+HOMEPAGE="https://www.spice-space.org/"
+SRC_URI="https://www.spice-space.org/download/libcacard/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+passthrough static-libs"
+
+RDEPEND=">=dev-libs/nss-3.13
+ >=dev-libs/glib-2.22
+ passthrough? ( >=sys-apps/pcsc-lite-1.8 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable passthrough pcsc) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc docs/*.txt
+ use static-libs || find "${ED}"/usr/ -name 'lib*.la' -delete
+}