summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-09-10 08:51:14 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-09-10 08:57:49 -0500
commitb25d9e9322b63018bccc65165b30b9ae57628a89 (patch)
tree3e5320001eef27c65b3c306eb9120e4a23aef3a6 /app-emulation/spice/spice-9999.ebuild
parentwww-client/chromium: enable gnome and gnome-keyring by default (diff)
downloadgentoo-b25d9e9322b63018bccc65165b30b9ae57628a89.tar.gz
gentoo-b25d9e9322b63018bccc65165b30b9ae57628a89.tar.bz2
gentoo-b25d9e9322b63018bccc65165b30b9ae57628a89.zip
app-emulation/spice: Call addpredict in appropriate function, bug #593388
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation/spice/spice-9999.ebuild')
-rw-r--r--app-emulation/spice/spice-9999.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/app-emulation/spice/spice-9999.ebuild b/app-emulation/spice/spice-9999.ebuild
index a5f3f7fe07b5..03da5f143703 100644
--- a/app-emulation/spice/spice-9999.ebuild
+++ b/app-emulation/spice/spice-9999.ebuild
@@ -42,10 +42,6 @@ DEPEND="
smartcard? ( app-emulation/qemu[smartcard] )
${RDEPEND}"
-# Prevent sandbox violations, bug #586560
-# https://bugzilla.gnome.org/show_bug.cgi?id=581836
-addpredict /dev
-
python_check_deps() {
has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
has_version "dev-python/six[${PYTHON_USEDEP}]"
@@ -61,6 +57,11 @@ src_prepare() {
}
src_configure() {
+ # Prevent sandbox violations, bug #586560
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
local myconf="
$(use_enable static-libs static)
$(use_enable lz4)
@@ -73,6 +74,15 @@ src_configure() {
econf ${myconf}
}
+src_compile() {
+ # Prevent sandbox violations, bug #586560
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
+ default
+}
+
src_install() {
default
use static-libs || prune_libtool_files