summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-29 11:20:37 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-29 15:28:52 -0500
commit99ef76018adf18ba73dcc7ae4cd34b5e0cf655fe (patch)
treeba72df86338f3532c3a055d4cfa42e3fd757246c /app-emulation/wine-staging/files
parentapp-emulation/wine-vanilla: drop 7.20, 7.21-r1 (diff)
downloadgentoo-99ef76018adf18ba73dcc7ae4cd34b5e0cf655fe.tar.gz
gentoo-99ef76018adf18ba73dcc7ae4cd34b5e0cf655fe.tar.bz2
gentoo-99ef76018adf18ba73dcc7ae4cd34b5e0cf655fe.zip
app-emulation/wine-staging: drop 7.20, 7.21-r1
Both versions had several quirks and shouldn't be worthwhile to keep, try 7.19 instead if 7.22 is not suitable (7.19 was before some more major changes). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-staging/files')
-rw-r--r--app-emulation/wine-staging/files/wine-staging-7.21-crossflags.patch29
-rw-r--r--app-emulation/wine-staging/files/wine-staging-7.21-opengl32.patch73
2 files changed, 0 insertions, 102 deletions
diff --git a/app-emulation/wine-staging/files/wine-staging-7.21-crossflags.patch b/app-emulation/wine-staging/files/wine-staging-7.21-crossflags.patch
deleted file mode 100644
index bdf5aeefb5bf..000000000000
--- a/app-emulation/wine-staging/files/wine-staging-7.21-crossflags.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Restore CROSSLDFLAGS and ensure tested flags are saved in
-{arch}_*FLAGS (e.g. -fno-strict-aliasing)
-
-quickfix, odds are this will be revamped upstream
---- a/configure.ac
-+++ b/configure.ac
-@@ -919,9 +919,9 @@
- saved_CC=$CC
- saved_CFLAGS=$CFLAGS
-+ saved_LDFLAGS=$LDFLAGS
-
- CFLAGS=${CROSSCFLAGS:-"-g -O2"}
-+ LDFLAGS=${CROSSLDFLAGS:-}
- AS_VAR_COPY([CC],[${wine_arch}_CC])
-- AS_VAR_COPY([${wine_arch}_CFLAGS],[CFLAGS])
-- AS_VAR_COPY([${wine_arch}_LDFLAGS],[LDFLAGS])
- AS_VAR_SET([${wine_arch}_EXTRACFLAGS],["-D__WINE_PE_BUILD -Wall"])
-
-@@ -1052,6 +1052,10 @@
- AS_VAR_APPEND([${wine_arch}_LDFLAGS],[" -Wl,--build-id"])])
-
-+ AS_VAR_COPY([${wine_arch}_CFLAGS],[CFLAGS])
-+ AS_VAR_COPY([${wine_arch}_LDFLAGS],[LDFLAGS])
-+
- CC=$saved_CC
- CFLAGS=$saved_CFLAGS
-+ LDFLAGS=$saved_LDFLAGS
- done
-
diff --git a/app-emulation/wine-staging/files/wine-staging-7.21-opengl32.patch b/app-emulation/wine-staging/files/wine-staging-7.21-opengl32.patch
deleted file mode 100644
index 9411e05e96fd..000000000000
--- a/app-emulation/wine-staging/files/wine-staging-7.21-opengl32.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-Fixes PE opengl32.dll failing to initialize.
-
-https://gitlab.winehq.org/wine/wine/-/commit/34099bba6cb
-From: Rémi Bernon <rbernon@codeweavers.com>
-Date: Mon, 14 Nov 2022 11:55:51 +0100
-Subject: [PATCH] ntdll: Delay loading unixlibs until the functions are
- requested.
-
-Wine-Bug: https://bugs.winehq.org/show_bug.cgi?id=53909
---- a/dlls/ntdll/unix/virtual.c
-+++ b/dlls/ntdll/unix/virtual.c
-@@ -98,6 +98,7 @@ struct builtin_module
- unsigned int refcount;
- void *handle;
- void *module;
-+ char *unix_path;
- void *unix_handle;
- };
-
-@@ -583,6 +584,7 @@ static void add_builtin_module( void *module, void *handle )
- builtin->handle = handle;
- builtin->module = module;
- builtin->refcount = 1;
-+ builtin->unix_path = NULL;
- builtin->unix_handle = NULL;
- list_add_tail( &builtin_modules, &builtin->entry );
- }
-@@ -603,6 +605,7 @@ void release_builtin_module( void *module )
- list_remove( &builtin->entry );
- if (builtin->handle) dlclose( builtin->handle );
- if (builtin->unix_handle) dlclose( builtin->unix_handle );
-+ free( builtin->unix_path );
- free( builtin );
- }
- break;
-@@ -652,6 +655,8 @@ static NTSTATUS get_builtin_unix_funcs( void *module, BOOL wow, const void **fun
- LIST_FOR_EACH_ENTRY( builtin, &builtin_modules, struct builtin_module, entry )
- {
- if (builtin->module != module) continue;
-+ if (builtin->unix_path && !builtin->unix_handle)
-+ builtin->unix_handle = dlopen( builtin->unix_path, RTLD_NOW );
- if (builtin->unix_handle)
- {
- *funcs = dlsym( builtin->unix_handle, ptr_name );
-@@ -669,26 +674,19 @@ static NTSTATUS get_builtin_unix_funcs( void *module, BOOL wow, const void **fun
- */
- NTSTATUS load_builtin_unixlib( void *module, const char *name )
- {
-- void *handle;
- sigset_t sigset;
-- NTSTATUS status = STATUS_DLL_NOT_FOUND;
-+ NTSTATUS status = STATUS_SUCCESS;
- struct builtin_module *builtin;
-
-- if (!(handle = dlopen( name, RTLD_NOW ))) return status;
- server_enter_uninterrupted_section( &virtual_mutex, &sigset );
- LIST_FOR_EACH_ENTRY( builtin, &builtin_modules, struct builtin_module, entry )
- {
- if (builtin->module != module) continue;
-- if (!builtin->unix_handle)
-- {
-- builtin->unix_handle = handle;
-- status = STATUS_SUCCESS;
-- }
-+ if (!builtin->unix_path) builtin->unix_path = strdup( name );
- else status = STATUS_IMAGE_ALREADY_LOADED;
- break;
- }
- server_leave_uninterrupted_section( &virtual_mutex, &sigset );
-- if (status) dlclose( handle );
- return status;
- }
-