summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-07-16 11:40:41 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-07-16 12:56:36 -0400
commit645fe41c0375af4f9e72ec6cfe57a38154f3c668 (patch)
treed4d401c90b7209586e5df8a1c1a9fe8c98589678 /app-emulation
parentapp-emulation/vkd3d-proton: filter -fuse-ld for mingw (diff)
downloadgentoo-645fe41c0375af4f9e72ec6cfe57a38154f3c668.tar.gz
gentoo-645fe41c0375af4f9e72ec6cfe57a38154f3c668.tar.bz2
gentoo-645fe41c0375af4f9e72ec6cfe57a38154f3c668.zip
app-emulation/wine-vanilla: filter -fuse-ld for mingw
flag-o-matic is looking at respecting -fuse-ld for test-flags-CCLD, which is good but don't want this when doing the user-unexpected switch to mingw toolchain (filtering feels more solid either way). Users can use CROSSLDFLAGS directly if really need full control. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild4
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild4
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.11.ebuild4
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.12.ebuild4
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.9.ebuild4
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild4
6 files changed, 18 insertions, 6 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild
index c61cc6c56b04..998f4859e6e6 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0-r2.ebuild
@@ -299,7 +299,9 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
local mingwcc=${CROSSCC:-$(usex x86 i686 x86_64)-w64-mingw32-gcc}
: "${CROSSCFLAGS:=$(CC=${mingwcc} test-flags-CC ${CFLAGS:--O2})}"
- : "${CROSSLDFLAGS:=$(CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
+ : "${CROSSLDFLAGS:=$(
+ filter-flags '-fuse-ld=*'
+ CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
export CROSS{C,LD}FLAGS
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild
index 2fb6362afb24..ddd54410ad78 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild
@@ -297,7 +297,9 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
local mingwcc=${CROSSCC:-$(usex x86 i686 x86_64)-w64-mingw32-gcc}
: "${CROSSCFLAGS:=$(CC=${mingwcc} test-flags-CC ${CFLAGS:--O2})}"
- : "${CROSSLDFLAGS:=$(CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
+ : "${CROSSLDFLAGS:=$(
+ filter-flags '-fuse-ld=*'
+ CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
export CROSS{C,LD}FLAGS
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.11.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.11.ebuild
index 2fb6362afb24..ddd54410ad78 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.11.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.11.ebuild
@@ -297,7 +297,9 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
local mingwcc=${CROSSCC:-$(usex x86 i686 x86_64)-w64-mingw32-gcc}
: "${CROSSCFLAGS:=$(CC=${mingwcc} test-flags-CC ${CFLAGS:--O2})}"
- : "${CROSSLDFLAGS:=$(CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
+ : "${CROSSLDFLAGS:=$(
+ filter-flags '-fuse-ld=*'
+ CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
export CROSS{C,LD}FLAGS
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.12.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.12.ebuild
index 2fb6362afb24..ddd54410ad78 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.12.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.12.ebuild
@@ -297,7 +297,9 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
local mingwcc=${CROSSCC:-$(usex x86 i686 x86_64)-w64-mingw32-gcc}
: "${CROSSCFLAGS:=$(CC=${mingwcc} test-flags-CC ${CFLAGS:--O2})}"
- : "${CROSSLDFLAGS:=$(CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
+ : "${CROSSLDFLAGS:=$(
+ filter-flags '-fuse-ld=*'
+ CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
export CROSS{C,LD}FLAGS
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.9.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.9.ebuild
index 40974d38a1ce..3e08b94d9450 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.9.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.9.ebuild
@@ -297,7 +297,9 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
local mingwcc=${CROSSCC:-$(usex x86 i686 x86_64)-w64-mingw32-gcc}
: "${CROSSCFLAGS:=$(CC=${mingwcc} test-flags-CC ${CFLAGS:--O2})}"
- : "${CROSSLDFLAGS:=$(CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
+ : "${CROSSLDFLAGS:=$(
+ filter-flags '-fuse-ld=*'
+ CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
export CROSS{C,LD}FLAGS
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 2fb6362afb24..ddd54410ad78 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -297,7 +297,9 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
local mingwcc=${CROSSCC:-$(usex x86 i686 x86_64)-w64-mingw32-gcc}
: "${CROSSCFLAGS:=$(CC=${mingwcc} test-flags-CC ${CFLAGS:--O2})}"
- : "${CROSSLDFLAGS:=$(CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
+ : "${CROSSLDFLAGS:=$(
+ filter-flags '-fuse-ld=*'
+ CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
export CROSS{C,LD}FLAGS
fi