summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-06 21:12:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-06 23:23:04 -0400
commitb3be9046a73f5e5ba63a7ff4dd4981a0f4e87203 (patch)
treececac1445a4b80dd1425d2b63323b7dfe1b6492a /app-emulation
parentapp-emulation/wine-mono: add 9.3.0 (diff)
downloadgentoo-b3be9046a73f5e5ba63a7ff4dd4981a0f4e87203.tar.gz
gentoo-b3be9046a73f5e5ba63a7ff4dd4981a0f4e87203.tar.bz2
gentoo-b3be9046a73f5e5ba63a7ff4dd4981a0f4e87203.zip
app-emulation/wine-vanilla: update live
odbc seems to have reverted to the old dlopen+soname check method Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 27cb53b52387..22b468368b77 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -8,7 +8,7 @@ inherit autotools flag-o-matic multilib multilib-build optfeature
inherit prefix toolchain-funcs wrapper
WINE_GECKO=2.47.4
-WINE_MONO=9.2.0
+WINE_MONO=9.3.0
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -67,6 +67,7 @@ WINE_DLOPEN_DEPEND="
fontconfig? ( media-libs/fontconfig[${MULTILIB_USEDEP}] )
kerberos? ( virtual/krb5[${MULTILIB_USEDEP}] )
netapi? ( net-fs/samba[${MULTILIB_USEDEP}] )
+ odbc? ( dev-db/unixODBC[${MULTILIB_USEDEP}] )
sdl? ( media-libs/libsdl2[haptic,joystick,${MULTILIB_USEDEP}] )
ssl? ( net-libs/gnutls:=[${MULTILIB_USEDEP}] )
truetype? ( media-libs/freetype[${MULTILIB_USEDEP}] )
@@ -88,7 +89,6 @@ WINE_COMMON_DEPEND="
media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}]
media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
)
- odbc? ( dev-db/unixODBC[${MULTILIB_USEDEP}] )
opencl? ( virtual/opencl[${MULTILIB_USEDEP}] )
pcap? ( net-libs/libpcap[${MULTILIB_USEDEP}] )
pulseaudio? ( media-libs/libpulse[${MULTILIB_USEDEP}] )
@@ -254,7 +254,6 @@ src_configure() {
$(use_with mingw)
$(use_with netapi)
$(use_with nls gettext)
- $(use_with odbc)
$(use_with opencl)
$(use_with opengl)
$(use_with osmesa)
@@ -275,6 +274,7 @@ src_configure() {
$(use_with wayland)
$(use_with xcomposite)
$(use_with xinerama)
+ $(usev !odbc ac_cv_lib_soname_odbc=)
)
filter-lto # build failure