summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-09-16 11:22:57 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-09-16 11:45:50 -0500
commitbbe9610608fbccf6e6fd61a07460e0e2158c9c7b (patch)
tree5c8a27a4da3d86e5c2090eb9d62fa9a01945f8ba /app-emulation
parentdev-libs/leatherman: 1.7.1 stable amd64/x86 with cleanup (diff)
downloadgentoo-bbe9610608fbccf6e6fd61a07460e0e2158c9c7b.tar.gz
gentoo-bbe9610608fbccf6e6fd61a07460e0e2158c9c7b.tar.bz2
gentoo-bbe9610608fbccf6e6fd61a07460e0e2158c9c7b.zip
app-emulation/diskimagebuilder: 2.27.1 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.27.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index db4279c7f4cd..56c895fc9732 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-2.26.1.tar.gz 421821 BLAKE2B 11c0ba668494285f33f3461e1a2c091ce6d622e4be164c4ab56a93cd000c82cec6702a6ed2ae37007120320f053760473f45f58ad8b45ee14b7b3eb47ac82d9a SHA512 e8bb68d15fc0bdd4881e76a7277f3e5e481b77decb4591546a576eda015bf624da3746326735add299551e168b82ab8bb165a18a64e96532c5b846e49815528f
DIST diskimage-builder-2.27.0.tar.gz 421632 BLAKE2B 3899f65c3fe29a9a39410393585c12c977687c6cf2865fcb4a923780600f92f09211a65f7e69e9e0c00501bf6db21341c1a2f55fc066e53574f4ad1808464dba SHA512 90a84489e4a753d6aa2a445abf3eb1402c387036959055bcdb607b7daabaa43502bd0689d450a5e785271aa3a3f696cf20fced2dfda7b9c872d59a9e2f87cf30
+DIST diskimage-builder-2.27.1.tar.gz 422323 BLAKE2B ae0099187318d62c9e2441d24d3bf85816d617e923572ca6ee7ec92b45f882b00f40fa22744fd6e4687f4be2881b3325e8b519a34f4589fcf304ea7197fcebf4 SHA512 b1104e7730fc85ee7cca534ba24236969d13066275a06734c9a8841268d8243ab38ad420434e4bcba38e5604377f3c0c30df67a0a9e7439170380f6fba626d04
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.27.1.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.27.1.ebuild
new file mode 100644
index 000000000000..86d3bb124b34
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.27.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"