summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-07-19 13:21:54 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-07-19 13:22:22 -0700
commitf0ff428c4889509082676f5d6f0cc90886c646a8 (patch)
tree238c4ff7a1aa9e83c00c99aacc992b068513fe06 /app-eselect
parentdev-python/pythondialog: Drop 3.3.0 (diff)
downloadgentoo-f0ff428c4889509082676f5d6f0cc90886c646a8.tar.gz
gentoo-f0ff428c4889509082676f5d6f0cc90886c646a8.tar.bz2
gentoo-f0ff428c4889509082676f5d6f0cc90886c646a8.zip
app-eselect/eselect-python-20200719: Version bump
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-python/Manifest1
-rw-r--r--app-eselect/eselect-python/eselect-python-20200719.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-eselect/eselect-python/Manifest b/app-eselect/eselect-python/Manifest
index 5cbaab212b55..d56cf26998b7 100644
--- a/app-eselect/eselect-python/Manifest
+++ b/app-eselect/eselect-python/Manifest
@@ -1 +1,2 @@
DIST eselect-python-20190417.tar.bz2 46698 BLAKE2B 6f0acad0abb21d8e4768cbeb12f7e871c316a940ebae4c02bdb1336095991cb6b6bf05661ab659115a67f29a09f2a9b57cfb0868019606ed550b5aa1863f6f71 SHA512 a461263a50a29f0493127ee4a027e49ca4d7631e9c8d16cffc8bdb98cc7e75b0796e45e70951d5559fb86f0db14141a3ea6a53bd4cf1e0cc83ed5c7f24173695
+DIST eselect-python-20200719.tar.bz2 47313 BLAKE2B 37270b1f5ad3dfcd4e19c71ae74da585e803afe89c43f8b912bccf0fbdb936916cf58fc780b654692bb9e6ab44310514bae5f10d19dcde6a0e63042f76abe81d SHA512 4b205a099ad079e5e28d3fdbe774c22f54b7c16bff2d28b54d0e20ee36be2339e928d4050eed74ef969d5815bf4bb691bf5ed6e98023b28972da6d5c7d8a2545
diff --git a/app-eselect/eselect-python/eselect-python-20200719.ebuild b/app-eselect/eselect-python/eselect-python-20200719.ebuild
new file mode 100644
index 000000000000..745d4e05cb20
--- /dev/null
+++ b/app-eselect/eselect-python/eselect-python-20200719.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://dev.gentoo.org/~chutzpah/dist/misc/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# python-exec-2.4.2 for working -l option
+RDEPEND="
+ >=app-admin/eselect-1.2.3
+ >=dev-lang/python-exec-2.4.2
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == "99999999" ]] && eautoreconf
+}
+
+pkg_postinst() {
+ local py
+
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+
+ if has_version "=dev-lang/python-3*"; then
+ eselect python update "--python3" --if-unset
+ fi
+}