summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-20 21:37:54 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-20 21:37:54 -0400
commit48d712dd45ae7cd22fbc1405acf12f64608899ce (patch)
tree8762b83b5bbb70db987557ddbe1c716d63aa1edb /app-forensics
parentmedia-sound/ncmpc: version bump to 0.25 (diff)
downloadgentoo-48d712dd45ae7cd22fbc1405acf12f64608899ce.tar.gz
gentoo-48d712dd45ae7cd22fbc1405acf12f64608899ce.tar.bz2
gentoo-48d712dd45ae7cd22fbc1405acf12f64608899ce.zip
app-forensics/afflib: version bump to 3.7.8
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afflib/Manifest1
-rw-r--r--app-forensics/afflib/afflib-3.7.8.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-forensics/afflib/Manifest b/app-forensics/afflib/Manifest
index 6f04ddf1ae33..5554f49e2194 100644
--- a/app-forensics/afflib/Manifest
+++ b/app-forensics/afflib/Manifest
@@ -1,2 +1,3 @@
DIST afflib-3.7.4.tar.gz 569346 SHA256 74934ae60a76616442f1d593bdeb93dd6aa105b5dc8cee7e8e5d7529a77f46c0 SHA512 58791388a05d614dd5f219a74173de2ff0938a1f93b21e2dd0731aca52ea544ba60cc4325f0d284937467ce600a4302b7a2f724d84710ecc7f12db1a22a8e41c WHIRLPOOL db8d5f48aecc55bd4ee0e6f45552e37e6aa1621674d93a448ae5a5a6b3bba1ae9c40d8aac2211b6e27bf1ba72e1c998b9bb01e6c24298ef4287d7a117db9d820
DIST afflib-3.7.7.tar.gz 518933 SHA256 049acb8b430fc354de0ae8b8c2043c221a213bcb17259eb099e1d5523a9697bf SHA512 8698d66ab84601e5dcd64fcedf2087d5a8227895ed4009d314958eb223c56e0e59aa3e76d57f854a911f79194ae9c1ffc8af8e686310752744b43030c9e84e80 WHIRLPOOL bd3eb26aca379953b0b2d432cace22f84838a32e2f915a47e1a5d14e48ef133ab0aa40cf5de1c0656248181989bf2aa04ccb741a6e63bf7cdce34b101ef44641
+DIST afflib-3.7.8.tar.gz 518399 SHA256 1ffcf2e087a0f4396d5054f0171c69d44f15aa023aa787aafa7bb57d849f1db9 SHA512 a547ea459c479ccba1b4805bcbbac6f670abdccf8fe6685406d0662483a2b643652e3798e6396ecb24cfeea9bf711f636aeebb64794637ee54e7dbb62c0bdbb7 WHIRLPOOL b0fd9fd0e1d6c5b0900ff42883b4c243639df46dfd860c4767bdce128c0282d29b7f79b133b54dccd88a7c9cd67345590669a24031e7db6ca73bd48faabd43cc
diff --git a/app-forensics/afflib/afflib-3.7.8.ebuild b/app-forensics/afflib/afflib-3.7.8.ebuild
new file mode 100644
index 000000000000..36fa7f2bc638
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.7.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils python-single-r1
+
+MY_PN=AFFLIBv3
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="https://github.com/sshock/AFFLIBv3/"
+SRC_URI="https://github.com/sshock/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~x64-macos"
+IUSE="fuse ncurses python qemu readline s3 static-libs threads"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="dev-libs/expat
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses:0= )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ s3? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.7.1-python-module.patch
+ "${FILESDIR}"/${PN}-3.6.12-pyaff-header.patch
+)
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i '/FLAGS/s: -g::' configure.ac || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Hacks for automagic dependencies
+ use ncurses || export ac_cv_lib_ncurses_initscr=no
+ use readline || export ac_cv_lib_readline_readline=no
+
+ local myeconfargs=(
+ $(use_enable fuse)
+ $(use_enable python)
+ $(use_enable qemu)
+ $(use_enable s3)
+ $(use_enable static-libs static)
+ $(use_enable threads threading)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}