summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-27 01:46:27 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-27 15:57:00 -0400
commit3f2bdf7c13fd7cab9cb8b1e3ec8d6973e8f0c7ac (patch)
treef0caa8a0d02dca845e9d171e45acdd0594045814 /app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild
parentapp-i18n/fcitx-m17n: Specify slot in dependency on app-i18n/fcitx. (diff)
downloadgentoo-3f2bdf7c13fd7cab9cb8b1e3ec8d6973e8f0c7ac.tar.gz
gentoo-3f2bdf7c13fd7cab9cb8b1e3ec8d6973e8f0c7ac.tar.bz2
gentoo-3f2bdf7c13fd7cab9cb8b1e3ec8d6973e8f0c7ac.zip
app-i18n/fcitx-m17n: Version bump (0.2.4).
Diffstat (limited to 'app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild')
-rw-r--r--app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild b/app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild
new file mode 100644
index 000000000000..b88697a1c677
--- /dev/null
+++ b/app-i18n/fcitx-m17n/fcitx-m17n-0.2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-m17n"
+fi
+
+DESCRIPTION="m17n-provided input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-m17n"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-libs/m17n-lib
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=()