summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Qian <i@bitbili.net>2023-12-12 09:27:17 +0800
committerYixun Lan <dlan@gentoo.org>2024-01-11 11:16:39 +0000
commit058dc0b851f1a555afe2366a400613f518de055a (patch)
treef26fa94d951eb1e19fa86af8e6c6ee2cd9b981f9 /app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild
parentdev-vcs/stgit: add 2.4.2 (diff)
downloadgentoo-058dc0b851f1a555afe2366a400613f518de055a.tar.gz
gentoo-058dc0b851f1a555afe2366a400613f518de055a.tar.bz2
gentoo-058dc0b851f1a555afe2366a400613f518de055a.zip
app-i18n/fcitx-rime: add 5.1.4
Bug: https://bugs.gentoo.org/760501 Signed-off-by: Ryan Qian <i@bitbili.net> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild')
-rw-r--r--app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild b/app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild
new file mode 100644
index 000000000000..9285cd4196a8
--- /dev/null
+++ b/app-i18n/fcitx-rime/fcitx-rime-5.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+MY_PN="fcitx5-rime"
+DESCRIPTION="Chinese RIME input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-rime"
+SRC_URI="https://download.fcitx-im.org/fcitx5/fcitx5-rime/fcitx5-rime-${PV}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=app-i18n/fcitx-5.1.2:5
+ app-i18n/librime
+ app-i18n/rime-data
+ virtual/libintl
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"