summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-05-07 22:44:49 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-05-07 22:44:49 +0900
commita04b58b808db782b2ef9a7146fb698977b449fdd (patch)
tree73caacba4149fc0d01dffd5ae07c6574f4c44b49 /app-i18n/ibus-anthy
parentdev-lang/elixir: drop old (diff)
downloadgentoo-a04b58b808db782b2ef9a7146fb698977b449fdd.tar.gz
gentoo-a04b58b808db782b2ef9a7146fb698977b449fdd.tar.bz2
gentoo-a04b58b808db782b2ef9a7146fb698977b449fdd.zip
app-i18n/ibus-anthy: new upstream release
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/Manifest1
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.10.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
index ed4572478cd1..3212bf688c4a 100644
--- a/app-i18n/ibus-anthy/Manifest
+++ b/app-i18n/ibus-anthy/Manifest
@@ -1,2 +1,3 @@
+DIST ibus-anthy-1.5.10.tar.gz 758528 BLAKE2B 39496f5c3a5f2038f3f81e09504e472a32da85f27701741cbe77b576afcd8685c4f2209aaf24ef84420cbeec1614b251d2903c1ea4e7175a1014f92615399847 SHA512 963b1dfba18259aad2296c10de35f9f321b0169d6f85afa058ed57b6894fe4e1d44514ffadeee3c3108aac77f54aa645096ddf4bdb353fafaedb83d27d8c5d47
DIST ibus-anthy-1.5.4.tar.gz 592595 BLAKE2B d483079c72ee8a500f79dfa6a1fe28b6dc13b8a7671c4ef6aba8df5994d6f2e3cddc9c8ebafe173a9f4799f1073745c8b23ea2aa7438e93d8e84c4b2c1ec129c SHA512 8478e9ea14472d0153cc7a35feae4edea791476dc98cfc266b598f915376d267bd5db48ea0a676209d7a6fa680628116a30fec59afaf696477cfaa14082aad8d
DIST ibus-anthy-1.5.9.tar.gz 765672 BLAKE2B 88a2b935bfe1007bdcbd70af358509da77533a67df4b6d0be218b5f9d5e1c0ca093e62618765f1e2d7c06c2127458319bbf482ce8598398b9562ecec8a258301 SHA512 2f57db784ddbd4ea57afba245dc532fe4ee8c9fea5fc7df9b3ca26600816ef4c0626b4ebdbbd976826c391890216af587863707caa26c3926a6278cc6b720ef6
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.10.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.10.ebuild
new file mode 100644
index 000000000000..497c5293094f
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.10.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2-utils python-single-r1
+
+DESCRIPTION="Japanese Anthy engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/anthy
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-private-png \
+ --with-layout=default \
+ --with-python=${EPYTHON}
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ if ! has_version app-dicts/kasumi; then
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}