summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-16 22:49:33 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-16 22:49:33 +0900
commitdf6348cc5aee1d807fd94798503a7a0bd005cf3b (patch)
tree068a9713b5ce81515e567d653dc796a97f10f5e8 /app-i18n/ibus-table
parentapp-i18n/ibus-table: update SRC_URI (diff)
downloadgentoo-df6348cc5aee1d807fd94798503a7a0bd005cf3b.tar.gz
gentoo-df6348cc5aee1d807fd94798503a7a0bd005cf3b.tar.bz2
gentoo-df6348cc5aee1d807fd94798503a7a0bd005cf3b.zip
app-i18n/ibus-table: new upstream release
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/Manifest1
-rw-r--r--app-i18n/ibus-table/ibus-table-1.9.18.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index 67c6fd594970..260bf26fc917 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1 +1,2 @@
DIST ibus-table-1.5.0.tar.gz 432844 SHA256 6ba89c70c50773d43927769a2c608f71b282afbf3538188f65b9c89ebdc1a184 SHA512 2c52da1b4d6ae8aec29e97a8a413b388912cfcfd15860ba0e65c97b139b14f8a7d4087eb196d516abe731df03a2e4904666194414242da8cf1f3f0b54696248e WHIRLPOOL cec2ad28dd8fa936738e7e2ae1ffa3c0e96a6d5c6cf88c74a98ed0900c31464ba405c6e4449977936733dc28f3c7768f22bb216fca2a583f1679a7bcb596c39d
+DIST ibus-table-1.9.18.tar.gz 585309 SHA256 d0ef094c84c47c5ae490fc0c30a6afea0e0337559f5b7042d6b07e92dd86de37 SHA512 3f28269be1987023402eb6075b8e68b3bbba3c572a94551d072281677fde5fa14f8f4186455f8f9156b252934580c7a3837555d0edb46c76f13c8b109e26aca2 WHIRLPOOL 1d960d5a73266fb86f3f76bfa1789609d38f8a356bd2405b043f6c1123a84069bc2cfc34cb7c3e90d463b34ba987bedab5b14307380f4381a29fe2f712806977
diff --git a/app-i18n/ibus-table/ibus-table-1.9.18.ebuild b/app-i18n/ibus-table/ibus-table-1.9.18.ebuild
new file mode 100644
index 000000000000..910a6cef56ba
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.9.18.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ sed -i \
+ "s/python/${EPYTHON}/" \
+ engine/ibus-table-createdb.in \
+ engine/ibus-engine-table.in
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}