summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-12-22 16:42:34 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-12-22 16:42:34 +0900
commit13275d15ce86d5b3ed3c0646416b007ae344d6cd (patch)
treefe72db8b237d5a28a46d5e4bea94182c43f67c94 /app-i18n/ibus-typing-booster
parentapp-i18n/ibus-typing-booster: drop old (diff)
downloadgentoo-13275d15ce86d5b3ed3c0646416b007ae344d6cd.tar.gz
gentoo-13275d15ce86d5b3ed3c0646416b007ae344d6cd.tar.bz2
gentoo-13275d15ce86d5b3ed3c0646416b007ae344d6cd.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.27.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index a60a3433a2d8..a5a6f7c8f700 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1 +1,2 @@
DIST ibus-typing-booster-2.26.11.tar.gz 13334659 BLAKE2B 833bd3f86439369495105ab0013ee9e86b3505dce25b7effa763885137c1c14ee18c43d7d7cf6311c61729b19afe3943e9c64955b41f382a2cdcab00a2f1138b SHA512 1cd6f15831e7258bbb7cb02e59f2cc92d1e17cc9359a17a4b98a965c7bcc91d29ff562fc54007bbb67a331ad40123723852c65d16dc5944bfa6c480ac560641f
+DIST ibus-typing-booster-2.27.1.tar.gz 13410885 BLAKE2B d92a51969dc8a8491f02fa8044205b90105102f81e94f26fd346dbf6ed2c80a9d5f43319a50510077a5b1153596e970be76e11ca7f381fdece092d6be427338b SHA512 2c729d662084c17ccba998573d64e2fb762b65b9e7786c4803979524cf6c76defac3b61d4698c8a9d1fad459b563f7bfe255a38fc98d264cd5dfe23e1ac73b99
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.27.1.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.27.1.ebuild
new file mode 100644
index 000000000000..97351b6920ac
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.27.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}