summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild')
-rw-r--r--app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild b/app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild
new file mode 100644
index 000000000000..7317081da861
--- /dev/null
+++ b/app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib eutils autotools libtool
+
+MY_P=${PN}_2.5.2.99.pre2+cvs20030224
+
+DESCRIPTION="Chinese X Input Method"
+HOMEPAGE="http://cle.linux.org.tw/xcin/"
+SRC_URI="mirror://debian/pool/main/x/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/x/${PN}/${MY_P}-1.4.diff.gz"
+
+LICENSE="XCIN GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="debug nls unicode"
+
+RDEPEND=">=sys-libs/db-4.5
+ >=app-i18n/libtabe-0.2.6
+ unicode? ( media-fonts/hkscs-ming
+ media-fonts/arphicfonts )
+ dev-libs/libchewing
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P/_/-}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${MY_P}-1.4.diff
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ rm -f configure
+ cd script
+ elibtoolize
+ eautoreconf
+ mv configure ../
+ cd ..
+}
+
+src_compile() {
+ myconf="--with-xcin-rcdir=/etc
+ --with-xcin-dir=/usr/$(get_libdir)/xcin25
+ --with-db-lib=/usr/$(get_libdir)
+ --with-tabe-inc=/usr/include/tabe
+ --with-tabe-lib=/usr/$(get_libdir)
+ $(use_enable debug)"
+
+ econf ${myconf}
+ emake -j1 || die "emake failed."
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ program_prefix="${D}" \
+ install || die
+
+ for docdir in doc doc/En doc/En/internal doc/history doc/internal doc/modules; do
+ docinto ${docdir#doc/}
+ if use unicode; then
+ for doc in $(find ${docdir} -maxdepth '1' -type 'f'); do
+ iconv -f BIG5 -t UTF-8 --output=${doc}.UTF-8 ${doc}
+ mv ${doc}.UTF-8 ${doc}
+ done
+ fi
+ dodoc ${docdir}/*
+ done
+}