summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-08-27 04:54:04 +0800
committerYixun Lan <dlan@gentoo.org>2024-08-29 14:56:23 +0000
commit05f5173e4a084b61b9f29fe21f7304396bdd3b99 (patch)
tree942f0155bdfac317827a4a7f3fe2b65dcc6af257 /app-i18n
parentmedia-sound/abcmidi: Stabilize 2024.07.26 x86, #938675 (diff)
downloadgentoo-05f5173e4a084b61b9f29fe21f7304396bdd3b99.tar.gz
gentoo-05f5173e4a084b61b9f29fe21f7304396bdd3b99.tar.bz2
gentoo-05f5173e4a084b61b9f29fe21f7304396bdd3b99.zip
app-i18n/librime-lua: Version bump (20240819212322).
Closes: https://bugs.gentoo.org/936661 Closes: https://github.com/gentoo/gentoo/pull/38295 Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/librime-lua/Manifest1
-rw-r--r--app-i18n/librime-lua/librime-lua-20240819212322.ebuild49
-rw-r--r--app-i18n/librime-lua/librime-lua-99999999999999.ebuild9
3 files changed, 52 insertions, 7 deletions
diff --git a/app-i18n/librime-lua/Manifest b/app-i18n/librime-lua/Manifest
index 00d57a498cb6..9383c819627a 100644
--- a/app-i18n/librime-lua/Manifest
+++ b/app-i18n/librime-lua/Manifest
@@ -1 +1,2 @@
DIST librime-lua-20211030072627.tar.gz 27894 BLAKE2B a527e865a9945aa7d56cce3905bc80156b60ebf6323828ca40999cb73ebe8d8f66ddf6b0a1d6d5904f2bc754b5f8fe6ac1f5ecdc56351c2222a21429a0c2b701 SHA512 b15f85b0a18e5e05fa691a84aef7cf3689b4a5271a1d5b6f78ea42488f6dbe4dfc56a91fa547ca3636269b9c898d646d24d3a160096ace9927901f9fdba06e9c
+DIST librime-lua-20240819212322.tar.gz 45085 BLAKE2B 3f5d6f5282def197477ea45daadf56be22a41f3bc0f2d9254ec6c3c95d16a19ca63de5f8041c44547bc736146ad804ab6a3e95e19d49c3f344d36e083e173c9b SHA512 65177c6ab36e16393c0412fd75cbd1b7e8b45cbad0129743bee101db47d4575e45846709d7a76be59c51fed04a0fb97fa872750e0762e04774204ddbc8519831
diff --git a/app-i18n/librime-lua/librime-lua-20240819212322.ebuild b/app-i18n/librime-lua/librime-lua-20240819212322.ebuild
new file mode 100644
index 000000000000..d1f5dd7e4886
--- /dev/null
+++ b/app-i18n/librime-lua/librime-lua-20240819212322.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+LUA_COMPAT=( lua5-{3..4} )
+
+inherit cmake lua-single
+
+if [[ "${PV}" == "99999999999999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hchunhui/librime-lua"
+else
+ LIBRIME_LUA_GIT_REVISION="fa6563cf7b40f3bfbf09e856420bff8de6820558"
+fi
+
+DESCRIPTION="Lua module for RIME"
+HOMEPAGE="https://github.com/hchunhui/librime-lua"
+if [[ "${PV}" != "99999999999999" ]]; then
+ SRC_URI="https://github.com/hchunhui/${PN}/archive/${LIBRIME_LUA_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND=">=app-i18n/librime-1.6:0=
+ ${LUA_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/boost:0"
+
+if [[ "${PV}" != "99999999999999" ]]; then
+ S="${WORKDIR}/${PN}-${LIBRIME_LUA_GIT_REVISION}"
+fi
+
+src_prepare() {
+ sed \
+ -e "1icmake_minimum_required(VERSION 3.0)\nproject(${PN})\n" \
+ -e "s/ PARENT_SCOPE//" \
+ -e "\$a\\\n" \
+ -e "\$aadd_library(\${plugin_modules} MODULE \${plugin_objs})" \
+ -e "\$aset_target_properties(\${plugin_modules} PROPERTIES PREFIX \"\")" \
+ -e "\$atarget_link_libraries(\${plugin_modules} rime \${plugin_deps})" \
+ -e "\$ainstall(TARGETS \${plugin_modules} DESTINATION $(get_libdir)/rime-plugins)" \
+ -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
diff --git a/app-i18n/librime-lua/librime-lua-99999999999999.ebuild b/app-i18n/librime-lua/librime-lua-99999999999999.ebuild
index 2211e7aea769..9f01797781a9 100644
--- a/app-i18n/librime-lua/librime-lua-99999999999999.ebuild
+++ b/app-i18n/librime-lua/librime-lua-99999999999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -16,19 +16,14 @@ fi
DESCRIPTION="Lua module for RIME"
HOMEPAGE="https://github.com/hchunhui/librime-lua"
-if [[ "${PV}" == "99999999999999" ]]; then
- SRC_URI=""
-else
+if [[ "${PV}" != "99999999999999" ]]; then
SRC_URI="https://github.com/hchunhui/${PN}/archive/${LIBRIME_LUA_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="BSD MIT"
SLOT="0"
-KEYWORDS=""
-IUSE=""
REQUIRED_USE="${LUA_REQUIRED_USE}"
-BDEPEND=""
RDEPEND=">=app-i18n/librime-1.6:0=
${LUA_DEPS}"
DEPEND="${RDEPEND}