summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2020-04-04 16:58:55 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-04-09 15:37:44 +0300
commit09f7da87c083371c564470940476fcb88b5bcd9a (patch)
tree4c2a24d0f0eb56fab8d91a949520997f178b5aa8 /app-leechcraft
parentapp-leechcraft/lc-lmp: qtsql[sqlite] is an RDEPEND (diff)
downloadgentoo-09f7da87c083371c564470940476fcb88b5bcd9a.tar.gz
gentoo-09f7da87c083371c564470940476fcb88b5bcd9a.tar.bz2
gentoo-09f7da87c083371c564470940476fcb88b5bcd9a.zip
app-leechcraft/lc-core: remove sqlite USE flag, fix qtsql dep
sqlite is needed unconditionally now. Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-leechcraft')
-rw-r--r--app-leechcraft/lc-core/lc-core-9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/app-leechcraft/lc-core/lc-core-9999.ebuild b/app-leechcraft/lc-core/lc-core-9999.ebuild
index 214174697302..1de10d566587 100644
--- a/app-leechcraft/lc-core/lc-core-9999.ebuild
+++ b/app-leechcraft/lc-core/lc-core-9999.ebuild
@@ -11,7 +11,7 @@ DESCRIPTION="Core of LeechCraft, the modular network client"
SLOT="0"
KEYWORDS=""
-IUSE="debug doc postgres +qwt +sqlite"
+IUSE="debug doc postgres +qwt"
DEPEND="
dev-libs/boost:=
@@ -22,7 +22,7 @@ DEPEND="
dev-qt/qtgui:5
dev-qt/qtnetwork:5[ssl]
dev-qt/qtscript:5
- dev-qt/qtsql:5[postgres?,sqlite?]
+ dev-qt/qtsql:5
dev-qt/qtwebkit:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
@@ -30,6 +30,7 @@ DEPEND="
qwt? ( x11-libs/qwt:6 )
"
RDEPEND="${DEPEND}
+ dev-qt/qtsql:5[postgres?,sqlite]
dev-qt/qtsvg:5
|| (
kde-frameworks/oxygen-icons
@@ -41,8 +42,6 @@ BDEPEND="
doc? ( app-doc/doxygen )
"
-REQUIRED_USE="|| ( postgres sqlite )"
-
src_configure() {
local mycmakeargs=(
-DWITH_PLUGINS=False