summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-17 20:15:01 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-17 20:15:01 +0200
commit79b08430ff37225202a152b8484e4a984c84fa81 (patch)
treeb6415cbe6128909f320bd19300a1b0bde6e72e35 /app-misc/anki
parentapp-i18n/ibus-typing-booster: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP (diff)
downloadgentoo-79b08430ff37225202a152b8484e4a984c84fa81.tar.gz
gentoo-79b08430ff37225202a152b8484e4a984c84fa81.tar.bz2
gentoo-79b08430ff37225202a152b8484e4a984c84fa81.zip
app-misc/anki: PYTHON_MULTI_USEDEP -> PYTHON_USEDEP
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/anki')
-rw-r--r--app-misc/anki/anki-2.1.15-r1.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-misc/anki/anki-2.1.15-r1.ebuild b/app-misc/anki/anki-2.1.15-r1.ebuild
index f97f7bb0fbcb..b5fc94f7294f 100644
--- a/app-misc/anki/anki-2.1.15-r1.ebuild
+++ b/app-misc/anki/anki-2.1.15-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="sqlite"
inherit desktop optfeature python-single-r1 xdg
@@ -21,22 +21,22 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
- >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_MULTI_USEDEP}]
- >=dev-python/PyQtWebEngine-5.12[${PYTHON_MULTI_USEDEP}]
- >=dev-python/httplib2-0.7.4[${PYTHON_MULTI_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
- dev-python/decorator[${PYTHON_MULTI_USEDEP}]
- dev-python/jsonschema[${PYTHON_MULTI_USEDEP}]
- dev-python/markdown[${PYTHON_MULTI_USEDEP}]
- dev-python/requests[${PYTHON_MULTI_USEDEP}]
- dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_USEDEP}]
+ >=dev-python/PyQtWebEngine-5.12[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.4[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
')
"
BDEPEND="test? (
${RDEPEND}
$(python_gen_cond_dep '
- dev-python/nose[${PYTHON_MULTI_USEDEP}]
- dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
')
)
"