summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-07-07 20:23:32 +0300
committerMart Raudsepp <leio@gentoo.org>2019-07-07 20:29:08 +0300
commite6e1c2cbe28395f1b865a4581d309b8fbb82b31c (patch)
tree93af06ca2ee3ef4fbd0a8f293c4217d18357eb70 /app-misc/geoclue/geoclue-2.5.3-r2.ebuild
parentx11-libs/gtk+: remove old (diff)
downloadgentoo-e6e1c2cbe28395f1b865a4581d309b8fbb82b31c.tar.gz
gentoo-e6e1c2cbe28395f1b865a4581d309b8fbb82b31c.tar.bz2
gentoo-e6e1c2cbe28395f1b865a4581d309b8fbb82b31c.zip
app-misc/geoclue: 2.5 series packaging fixes, unmask
* Enable demo-agent as in 2.4.13, as it's the only known agent available for non-GNOME for actually having a geoclue service responding on other desktops than GNOME * Rewrite optional vapi patch to not need sedding * Port to EAPI-7 * Add missing REQUIRED_USE="vala? ( introspection )" * Drop unnecessary bogus VALA_MIN_API_VERSION * Drop unnecessary gnome.org.eclass inherit * Fix LICENSE * Fix gtk-doc dep to be conditional to USE=gtk-doc, add missing docbook-xml-dtd dep * Reorder emesonargs to meson_options.txt order for easier (future) review and drop unnecessary backslashes at EOLs * Various other touchups * Unmask it now together with newer xdg-desktop-portal, as it's been reviewed now Closes: https://bugs.gentoo.org/678814 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-misc/geoclue/geoclue-2.5.3-r2.ebuild')
-rw-r--r--app-misc/geoclue/geoclue-2.5.3-r2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/app-misc/geoclue/geoclue-2.5.3-r2.ebuild b/app-misc/geoclue/geoclue-2.5.3-r2.ebuild
new file mode 100644
index 000000000000..73bd1075be74
--- /dev/null
+++ b/app-misc/geoclue/geoclue-2.5.3-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit meson systemd vala user xdg
+
+DESCRIPTION="A location information D-Bus service"
+HOMEPAGE="https://gitlab.freedesktop.org/geoclue/geoclue/wikis/home"
+SRC_URI="https://gitlab.freedesktop.org/geoclue/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+ GPL-2+"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="+introspection gtk-doc modemmanager vala zeroconf"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.14.0
+ >=net-libs/libsoup-2.42.0:2.4
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ modemmanager? ( >=net-misc/modemmanager-1.6 )
+ zeroconf? ( >=net-dns/avahi-0.6.10[dbus] )
+ x11-libs/libnotify
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ gtk-doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-optional-vapi.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dlibgeoclue=true
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ $(meson_use gtk-doc)
+ $(meson_use modemmanager 3g-source)
+ $(meson_use modemmanager cdma-source)
+ $(meson_use modemmanager modem-gps-source)
+ $(meson_use zeroconf nmea-source)
+ -Denable-backend=true
+ -Ddemo-agent=true
+ -Dsystemd-system-unit-dir="$(systemd_get_systemunitdir)"
+ -Ddbus-srv-user=geoclue
+ )
+ meson_src_configure
+}
+
+pkg_preinst() {
+ enewgroup geoclue
+ enewuser geoclue -1 -1 /var/lib/geoclue geoclue
+}