summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBailey Kasin <baileykasin@gmail.com>2023-10-20 00:11:04 -0700
committerJoonas Niilola <juippis@gentoo.org>2023-10-20 10:29:45 +0300
commit6fb8c321abb5af9f53eb29c66c4abe7c457fe4b2 (patch)
treee3ef2a4600a2f0d73d223c1bce92b1611c505a5c /app-misc/hyfetch/hyfetch-1.4.10.ebuild
parentnet-libs/gsoap: Fix incompatible integer to pointer conversion (diff)
downloadgentoo-6fb8c321abb5af9f53eb29c66c4abe7c457fe4b2.tar.gz
gentoo-6fb8c321abb5af9f53eb29c66c4abe7c457fe4b2.tar.bz2
gentoo-6fb8c321abb5af9f53eb29c66c4abe7c457fe4b2.zip
app-misc/hyfetch: new package, add 1.4.10, 9999
Closes: https://github.com/gentoo/gentoo/pull/32681 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/hyfetch/hyfetch-1.4.10.ebuild')
-rw-r--r--app-misc/hyfetch/hyfetch-1.4.10.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/hyfetch/hyfetch-1.4.10.ebuild b/app-misc/hyfetch/hyfetch-1.4.10.ebuild
new file mode 100644
index 000000000000..076daa812814
--- /dev/null
+++ b/app-misc/hyfetch/hyfetch-1.4.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit optfeature distutils-r1
+
+DESCRIPTION="Neofetch with LGBTQ+ pride flags!"
+HOMEPAGE="https://github.com/hykilpikonna/hyfetch"
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hykilpikonna/hyfetch.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hykilpikonna/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.10-config_fix.patch
+)
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+ elog "The standard neofetch is installed as 'neowofetch', to avoid name conflicts."
+ elog "So if you do not wish to use the pride flag functionality, you can call the"
+ elog "tool that way instead."
+}