summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Komínek <drake127@planescape.cz>2024-05-03 11:50:53 +0200
committerAmy Liffey <amynka@gentoo.org>2024-05-04 12:37:08 +0200
commit5e588272094cafb61ee3924b87c2637179e88945 (patch)
tree760f8ed5193b3accbfb352b3b058a8eb74bc5317 /app-misc/libdatovka/libdatovka-0.6.2.ebuild
parentapp-misc/datovka: add 4.23.7 (diff)
downloadgentoo-5e588272094cafb61ee3924b87c2637179e88945.tar.gz
gentoo-5e588272094cafb61ee3924b87c2637179e88945.tar.bz2
gentoo-5e588272094cafb61ee3924b87c2637179e88945.zip
app-misc/libdatovka: add 0.6.2
Closes: https://github.com/gentoo/gentoo/pull/36525 Signed-off-by: Emanuel Komínek <drake127@planescape.cz> Signed-off-by: Amy Liffey <amynka@gentoo.org>
Diffstat (limited to 'app-misc/libdatovka/libdatovka-0.6.2.ebuild')
-rw-r--r--app-misc/libdatovka/libdatovka-0.6.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-misc/libdatovka/libdatovka-0.6.2.ebuild b/app-misc/libdatovka/libdatovka-0.6.2.ebuild
new file mode 100644
index 000000000000..da916814f61e
--- /dev/null
+++ b/app-misc/libdatovka/libdatovka-0.6.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Client library for accessing ISDS SOAP services"
+HOMEPAGE="https://www.datovka.cz/cs/pages/libdatovka.html"
+SRC_URI="https://secure.nic.cz/files/datove_schranky/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+curl debug doc nls openssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/libxml2
+ curl? ( net-misc/curl[ssl] )
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+ openssl? ( dev-libs/openssl:= )
+ !openssl? (
+ app-crypt/gnupg
+ app-crypt/gpgme:=
+ dev-libs/libgcrypt:=
+ )"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fatalwarnings
+ --disable-static
+ $(use_with curl libcurl)
+ $(use_enable curl curlreauthorizationbug)
+ $(use_enable doc)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable openssl openssl-backend)
+ $(use_enable test)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}