summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2025-01-16 11:59:48 +0200
committerViorel Munteanu <ceamac@gentoo.org>2025-01-16 19:00:28 +0200
commit25e79ff70f6f956bf856744d3dc3fefbb5680623 (patch)
treeba188430d2c4f1d529079628e85abf82b2822420 /app-misc/mc
parentapp-misc/fastfetch: add 2.34.1 (diff)
downloadgentoo-25e79ff70f6f956bf856744d3dc3fefbb5680623.tar.gz
gentoo-25e79ff70f6f956bf856744d3dc3fefbb5680623.tar.bz2
gentoo-25e79ff70f6f956bf856744d3dc3fefbb5680623.zip
app-misc/mc: add 4.8.33_rc1
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/Manifest1
-rw-r--r--app-misc/mc/mc-4.8.33_rc1.ebuild147
2 files changed, 148 insertions, 0 deletions
diff --git a/app-misc/mc/Manifest b/app-misc/mc/Manifest
index f767fac30fec..250bbb63f2a4 100644
--- a/app-misc/mc/Manifest
+++ b/app-misc/mc/Manifest
@@ -1,2 +1,3 @@
DIST mc-4.8.30.tar.xz 2380824 BLAKE2B 2bf759314abae39db7596426cba22f6eaac0efc58e7025f1a7ef1863496ea7a3c00d298d101123b9defb109e76e31fe988227fb5c1112e06051b3c7a5b3dc1b6 SHA512 f793f744eaff236c9952d477236dd775a24d9ddd7ff46940bfe2d06da5596bed91d6bd9c85250696da6dcdc0a1890dc01c736654df3f59039674eff38e12e68e
DIST mc-4.8.32.tar.xz 2385648 BLAKE2B eb2ac2474c86dbcfe43b4f229cdc458bdfc9de2acf1d0206198721b56ec188010aba24063c1fc079ada295c73ab915786749be1ead599a582832ca649b9a8347 SHA512 f7f46e4f065331ede638a79c821ab5ef65952ba99cf71710d4282efa9ed7de75f06c786a8f8feb27d487417f438a48959439b40bb6456eb64796d46518a3f4a8
+DIST mc-4.8.33_rc1.tar.gz 3119661 BLAKE2B 18d2f98c488a7d440e38ebc5006e10c5543b59392ed0cdc50949e8bec0c09733867a9411237edf3e15501eac7ad6ba72c288bf4c985605e5e70f6cdc54bc88ce SHA512 1a56e5c3b320b2778f9d80fc1b8f95f1ba7ef2ccc3a6bdad0bc4b795a015e3906fb914c011699787607b59a86c1ff650577aa0018f9b07f36cdd31631e8dca83
diff --git a/app-misc/mc/mc-4.8.33_rc1.ebuild b/app-misc/mc/mc-4.8.33_rc1.ebuild
new file mode 100644
index 000000000000..38a14b263024
--- /dev/null
+++ b/app-misc/mc/mc-4.8.33_rc1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+MY_P="${P/_/-}"
+MY_PV="${PV/_rc/-pre}"
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="https://midnight-commander.org"
+SRC_URI="https://github.com/MidnightCommander/mc/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+edit gpm sftp +slang spell test unicode X"
+
+REQUIRED_USE="spell? ( edit )"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.30.0:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs[tools(+)] )
+ sftp? ( net-libs/libssh2 )
+ slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses:=[unicode(+)?] )
+ spell? ( app-text/aspell )
+ X? (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ )
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+RDEPEND="
+ ${DEPEND}
+ spell? ( app-dicts/aspell-en )
+"
+
+# Force nls so xgettext is installed. Will revert this.
+BDEPEND="
+ sys-devel/gettext
+ app-arch/xz-utils
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.26-ncurses-mouse.patch
+ "${FILESDIR}"/${PN}-4.8.29-gentoo-tools.patch
+)
+
+# This is a check for AIX, on Linux mc uses statvfs() regardless of whether
+# LFS64 interfaces are available in libc or not.
+QA_CONFIG_IMPL_DECL_SKIP=(
+ statvfs64
+)
+
+src_prepare() {
+ default
+
+ # Bug #906194, #922483
+ if use elibc_musl; then
+ eapply "${FILESDIR}"/${PN}-4.8.30-musl-tests.patch
+ eapply "${FILESDIR}"/${PN}-4.8.31-musl-tests.patch
+ fi
+
+ eautoreconf
+
+ # Copied from autogen.sh
+ xgettext --keyword=_ --keyword=N_ --keyword=Q_ --output=- \
+ `find . -name '*.[ch]'` | sed -ne '/^#:/{s/#://;s/:[0-9]*/\
+/g;s/ //g;p;}' | \
+ grep -v '^$' | sort | uniq >po/POTFILES.in || die
+
+}
+
+src_configure() {
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"
+
+ local myeconfargs=(
+ --enable-charset
+ --enable-vfs
+ --with-screen=$(usex slang 'slang' "ncurses$(usex unicode 'w' '')")
+ $(use_enable kernel_linux vfs-undelfs)
+ # Today mclib does not expose any headers and is linked to
+ # single 'mc' binary. Thus there is no advantage of having
+ # a library. Let's avoid shared library altogether
+ # as it also conflicts with sci-libs/mc: bug #685938
+ --disable-mclib
+ --enable-nls
+ $(use_enable sftp vfs-sftp)
+ $(use_enable spell aspell)
+ $(use_enable test tests)
+ $(use_with gpm gpm-mouse)
+ $(use_with X x)
+ $(use_with edit internal-edit)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Bug #759466
+ if [[ ${EUID} == 0 ]] ; then
+ ewarn "You are emerging ${PN} as root with 'userpriv' disabled."
+ ewarn "Expect some test failures, or emerge with 'FEATURES=userpriv'!"
+ fi
+
+ # CK_FORK=no to avoid using fork() in check library
+ # as mc mocks fork() itself: bug #644462.
+ #
+ # VERBOSE=1 to make test failures contain detailed
+ # information.
+ CK_FORK=no emake check VERBOSE=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS doc/{NEWS,README,TODO,FAQ}
+
+ # fix bug #334383
+ if use kernel_linux && [[ ${EUID} == 0 ]] ; then
+ fowners root:tty /usr/libexec/mc/cons.saver
+ fperms g+s /usr/libexec/mc/cons.saver
+ fi
+}
+
+pkg_postinst() {
+ elog "${PN} extension scripts depend on many external tools, install them as needed"
+ elog
+ if use spell && ! has_version app-dicts/aspell-en ; then
+ elog "'spell' USE flag is enabled however app-dicts/aspell-en is not installed."
+ elog "You should manually set 'spell_language' in the Misc section of ~/.config/mc/ini"
+ elog "It has to be set to one of your installed aspell dictionaries or 'NONE'"
+ elog
+ fi
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}