summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas PARLANT <nicolas.parlant@parhuet.fr>2025-01-06 20:52:48 +0000
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-07 23:33:57 +0100
commit05b8ab1f952863ef9834577d23280f1938f2279b (patch)
treed269b7b894bc9f409834273769cd62a9aca0fb62 /app-misc/socnetv
parentmedia-video/guvcview: add 2.2.1 (diff)
downloadgentoo-05b8ab1f952863ef9834577d23280f1938f2279b.tar.gz
gentoo-05b8ab1f952863ef9834577d23280f1938f2279b.tar.bz2
gentoo-05b8ab1f952863ef9834577d23280f1938f2279b.zip
app-misc/socnetv: add 3.1
update EAPI 7 -> 8 license is now GPL-3+ : https://github.com/socnetv/app/commit/97d200c0ec681e8de06e4c4330121536c525ef66 qt5 -> qt6 dev-qt/qtsvg is required to render icons project moved from sourceforge to github use examples deleted. dir no longer exists in repo Closes: https://bugs.gentoo.org/822774 Signed-off-by: Nicolas PARLANT <nicolas.parlant@parhuet.fr> Closes: https://github.com/gentoo/gentoo/pull/40019 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-misc/socnetv')
-rw-r--r--app-misc/socnetv/Manifest1
-rw-r--r--app-misc/socnetv/files/socnetv-3.1-deps.patch13
-rw-r--r--app-misc/socnetv/socnetv-3.1.ebuild35
3 files changed, 49 insertions, 0 deletions
diff --git a/app-misc/socnetv/Manifest b/app-misc/socnetv/Manifest
index 197a7fe7f8b2..13b4cb7a5df9 100644
--- a/app-misc/socnetv/Manifest
+++ b/app-misc/socnetv/Manifest
@@ -1 +1,2 @@
DIST SocNetV-2.2.tar.gz 745086 BLAKE2B 3b520df2bb29f1989f744ec7e424caecd722cf3f903cf494e0fba9c0e5c1def413411768f593a3f8c0eb3cc20d1071d54babbd76eb24aac9f6670b4f2623ceb7 SHA512 12f490fd1f7fc1a6b45f77d23d8825117def0b7720595cd203d171fd88c41d5a0194a70359f55cbe2dab9e545f300156b31bb0680e46d7ab584e070e128e457b
+DIST socnetv-3.1.tar.gz 808640 BLAKE2B 377b42cb7420b60f1dc0edc4e000f2d5a5cc230170f7fe39f64c7a6a6147ea5f9797e59c57a3b43abbc4fd7e2bddd7338c87a0e954154d20eb87a70dcc5b2141 SHA512 2d18e3262dba71b7bdb4cbe3f453b931923a1b132a98c08046d91b6c535a5f137aedbf581043cb0c8640bbd276aa32801661b443d15fac8e03ab481fbcf9dc5e
diff --git a/app-misc/socnetv/files/socnetv-3.1-deps.patch b/app-misc/socnetv/files/socnetv-3.1-deps.patch
new file mode 100644
index 000000000000..89c40f5d8a45
--- /dev/null
+++ b/app-misc/socnetv/files/socnetv-3.1-deps.patch
@@ -0,0 +1,13 @@
+src/parser.h calls two classes provided by dev-qt/qtbase[-xml] :
+QXmlStreamReader
+QXmlStreamAttributes
+--- a/socnetv.pro
++++ b/socnetv.pro
+@@ -16,7 +16,6 @@
+
+ # add Qt module support
+ QT += core
+-QT += xml
+ QT += network
+ QT += widgets
+ QT += printsupport
diff --git a/app-misc/socnetv/socnetv-3.1.ebuild b/app-misc/socnetv/socnetv-3.1.ebuild
new file mode 100644
index 000000000000..4198a4c24436
--- /dev/null
+++ b/app-misc/socnetv/socnetv-3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Qt Social Network Visualizer"
+HOMEPAGE="https://socnetv.org/"
+SRC_URI="https://github.com/socnetv/app/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/app-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[gui,network,widgets]
+ dev-qt/qtcharts:6
+ dev-qt/qtsvg:6
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.1-deps.patch )
+
+src_configure() {
+ eqmake6 socnetv.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}