summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2015-10-15 09:54:43 +0200
committerTobias Klausmann <klausman@gentoo.org>2015-10-15 09:55:04 +0200
commit2a7d91b0eddd37dd872d75747e45dc8fd664895d (patch)
treeb5d080c1b28e12a60e80127d77d3efc33242f2b6 /app-misc
parentnet-libs/onion: Initial import. Ebuild be me. (diff)
downloadgentoo-2a7d91b0eddd37dd872d75747e45dc8fd664895d.tar.gz
gentoo-2a7d91b0eddd37dd872d75747e45dc8fd664895d.tar.bz2
gentoo-2a7d91b0eddd37dd872d75747e45dc8fd664895d.zip
app-misc/tmux: Add dependency on the fixed version of libevent
libevent has a patch for the Zombie bug, but it is in none of the released versions. Let's use it to unbreak tmux after 6mo of Zombies. Gentoo-Bug: 540456 Libevent-Bug: http://sourceforge.net/p/levent/bugs/350/ Package-Manager: portage-2.2.23
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tmux/tmux-2.0-r4.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/app-misc/tmux/tmux-2.0-r4.ebuild b/app-misc/tmux/tmux-2.0-r4.ebuild
new file mode 100644
index 000000000000..8696d53c6f95
--- /dev/null
+++ b/app-misc/tmux/tmux-2.0-r4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils bash-completion-r1 flag-o-matic
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug selinux vim-syntax"
+
+CDEPEND="
+ || ( =dev-libs/libevent-2.0*
+ >=dev-libs/libevent-2.1.5-r4 )
+ !sys-apps/utempter
+ sys-libs/ncurses"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-screen )
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+
+DOCS=( CHANGES FAQ README TODO )
+
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
+
+pkg_setup() {
+ if has_version "<app-misc/tmux-1.9a"; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn
+ ewarn "WARNING: After updating to ${P} you will _not_ be able to connect to any"
+ ewarn "older, running tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to access them."
+ echo
+ fi
+}
+
+src_prepare() {
+ # bug 438558
+ # 1.7 segfaults when entering copy mode if compiled with -Os
+ replace-flags -Os -O2
+
+ # regenerate aclocal.m4 to support earlier automake versions
+ rm aclocal.m4 || die
+
+ # remove generated files
+ rm -r compat/.{dirstamp,deps} || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newbashcomp examples/bash_completion_tmux.sh ${PN}
+
+ docinto examples
+ dodoc examples/*.conf
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim
+ fi
+}