summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-12-29 23:45:17 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-31 03:47:43 +0100
commit5735ba84a3c963d66d6b237000829c0ed2af4af5 (patch)
tree93848f474ed329e75f99e0f11ffe20b06262c56e /app-misc
parentapp-benchmarks/ioping: fix LICENSE, fix bug #866722 (diff)
downloadgentoo-5735ba84a3c963d66d6b237000829c0ed2af4af5.tar.gz
gentoo-5735ba84a3c963d66d6b237000829c0ed2af4af5.tar.bz2
gentoo-5735ba84a3c963d66d6b237000829c0ed2af4af5.zip
app-misc/cfiles: EAPI8 bump, fix bug #722342, #726636
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/722342 Closes: https://bugs.gentoo.org/726636 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/cfiles/cfiles-1.8-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/cfiles/cfiles-1.8-r1.ebuild b/app-misc/cfiles/cfiles-1.8-r1.ebuild
new file mode 100644
index 000000000000..9c1566d0f94a
--- /dev/null
+++ b/app-misc/cfiles/cfiles-1.8-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Ncurses file manager written in C with vim like keybindings"
+HOMEPAGE="https://github.com/mananapr/cfiles"
+SRC_URI="https://github.com/mananapr/cfiles/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ sys-libs/ncurses:=
+ app-text/poppler[utils]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/$(CC) $(CFLAGS)/& $(LDFLAGS)/g' Makefile || die
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin cfiles
+ dobin scripts/displayimg_uberzug
+ dobin scripts/clearimg_uberzug
+ dobin scripts/displayimg
+ doman cfiles.1
+}