summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-05-14 18:36:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2022-05-15 00:56:09 +0200
commita408da145fd50df02054ca80583b5417e477a112 (patch)
treea84a25dd62779277ca4b7aa19d7b4ae143522bf8 /app-misc
parentapp-misc/g15daemon: Updated live ebuild (diff)
downloadgentoo-a408da145fd50df02054ca80583b5417e477a112.tar.gz
gentoo-a408da145fd50df02054ca80583b5417e477a112.tar.bz2
gentoo-a408da145fd50df02054ca80583b5417e477a112.zip
app-misc/g15daemon: Bump to version 3.0.4
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/g15daemon/Manifest1
-rw-r--r--app-misc/g15daemon/g15daemon-3.0.4.ebuild157
2 files changed, 158 insertions, 0 deletions
diff --git a/app-misc/g15daemon/Manifest b/app-misc/g15daemon/Manifest
index 7a3f74981600..876c54484337 100644
--- a/app-misc/g15daemon/Manifest
+++ b/app-misc/g15daemon/Manifest
@@ -1 +1,2 @@
DIST g15daemon-1.9.5.3.tar.gz 414603 BLAKE2B 4f683bab47f6cbde3a028b306c1999ea4fcb84c0c05160a17374be93f953d21588f332e8fbf040c607545c31ee09e30b56b1068db95a801472c9d72ee9fe8e43 SHA512 7a1770d08d1d4155866bba3b676d33bf943363f4519af41a13ab6ec73cc5d6c536b173977b3e3583b594b149b7f01ffbc51123a4678c2a249a51ff0b42c8b69a
+DIST g15daemon-3.0.4.tar.bz2 372553 BLAKE2B 008cf2eda9e8cbc45a2fd2eef938438be73236f2bffbbc47bdce66f04d6860705572270994df09bc1d7c2c02dc75ca347199e02dc7aa9f71134985cff284c7c8 SHA512 4adbb11ca8128bbaff5ad1dee17ddcfcdfca589f7e8a1a264127dd9d5aec39e07e4986a4b78f4199fb7f3e12979fd8d50a851b047b6cb8cfa13410aa59df062a
diff --git a/app-misc/g15daemon/g15daemon-3.0.4.ebuild b/app-misc/g15daemon/g15daemon-3.0.4.ebuild
new file mode 100644
index 000000000000..991e249327e9
--- /dev/null
+++ b/app-misc/g15daemon/g15daemon-3.0.4.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic linux-info perl-module systemd toolchain-funcs udev
+
+DESCRIPTION="Takes control of the G15 keyboard, through the linux kernel uinput device driver"
+HOMEPAGE="https://gitlab.com/menelkir/g15daemon"
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/menelkir/g15daemon.git"
+else
+ SRC_URI="https://gitlab.com/menelkir/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="perl static-libs"
+
+# Has no "test" target in Makefile
+RESTRICT="test"
+
+DEPEND="virtual/libusb:0
+ >=dev-libs/libg15-3.0
+ >=dev-libs/libg15render-3.0
+ perl? (
+ dev-lang/perl
+ dev-perl/GDGraph
+ >=dev-perl/Inline-0.4
+ )"
+RDEPEND="${DEPEND}"
+
+uinput_check() {
+ ebegin "Checking for uinput support"
+ local rc=1
+ linux_config_exists && linux_chkconfig_present INPUT_UINPUT
+ rc=$?
+ eend ${rc}
+
+ if [[ ${rc} -ne 0 ]] ; then
+ eerror "To use g15daemon, you need to compile your kernel with uinput support."
+ eerror "Please enable uinput support in your kernel config, found at:"
+ eerror
+ eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
+ eerror
+ eerror "Once enabled, you should have the /dev/input/uinput device."
+ eerror "g15daemon will not work without the uinput device."
+ fi
+}
+
+pkg_setup() {
+ export CC="$(tc-getCC)" #729294
+
+ linux-info_pkg_setup
+ uinput_check
+}
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]] ; then
+ git-r3_src_unpack
+ else
+ default
+ fi
+
+ if use perl ; then
+ unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
+ fi
+}
+
+src_prepare() {
+ if use perl ; then
+ perl-module_src_prepare
+ sed -i \
+ -e '1i#!/usr/bin/perl' \
+ "${S}"/contrib/testbindings.pl || die
+ else
+ # perl-module_src_prepare always calls base_src_prepare
+ default
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -fcommon #706712
+
+ econf $(use_enable static-libs static)
+
+ if use perl ; then
+ cd "${WORKDIR}/G15Daemon-0.2" || die
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ if use perl ; then
+ cd "${WORKDIR}/G15Daemon-0.2" || die
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ # remove odd docs installed my make
+ rm "${ED}"/usr/share/doc/${PF}/README.usage || die
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/xmodmaprc{,-alternative}
+ doins contrib/xmodmap.sh
+ if use perl ; then
+ doins contrib/testbindings.pl
+ fi
+
+ newconfd "${FILESDIR}/${PN}-1.2.7.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}-1.9.5.3.initd" ${PN}
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ dobin "${FILESDIR}/g15daemon-hotplug"
+ udev_dorules "${FILESDIR}/99-g15daemon.rules"
+
+ insinto /etc
+ doins "${FILESDIR}"/g15daemon.conf
+
+ # Gentoo bug #301340, debian bug #611649
+ exeinto /usr/lib/pm-utils/sleep.d
+ doexe "${FILESDIR}"/20g15daemon
+
+ if use perl ; then
+ einfo "Installing Perl Bindings (G15Daemon.pm)"
+ cd "${WORKDIR}/G15Daemon-0.2" || die
+ docinto perl
+ perl-module_src_install
+ fi
+}
+
+pkg_postinst() {
+ udev_reload
+
+ elog "To use g15daemon, you need to add g15daemon to the default runlevel."
+ elog "This can be done with:"
+ elog "# /sbin/rc-update add g15daemon default"
+ elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
+ elog ""
+ elog "To have all new keys working in X11, you'll need create a "
+ elog "specific xmodmap in your home directory or edit the existent one."
+ elog ""
+ elog "Create the xmodmap:"
+ elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+ elog ""
+ elog "Adding keycodes to an existing xmodmap:"
+ elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+}