summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-12-24 11:36:54 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-25 00:16:32 +0100
commitcabe729b786afded2fcf3cf9abc2ce75ce204e6b (patch)
treea3c48d67263f5ef39ee613e1175a8a291879a154 /app-misc
parentsys-block/flashbench: EAPI8 bump (diff)
downloadgentoo-cabe729b786afded2fcf3cf9abc2ce75ce204e6b.tar.gz
gentoo-cabe729b786afded2fcf3cf9abc2ce75ce204e6b.tar.bz2
gentoo-cabe729b786afded2fcf3cf9abc2ce75ce204e6b.zip
app-misc/pal: EAPI8 bump, fix #729400
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/729400 Closes: https://github.com/gentoo/gentoo/pull/34456 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/pal/pal-0.4.3-r2.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-misc/pal/pal-0.4.3-r2.ebuild b/app-misc/pal/pal-0.4.3-r2.ebuild
index 039c608cd2df..7066a7b151d0 100644
--- a/app-misc/pal/pal-0.4.3-r2.ebuild
+++ b/app-misc/pal/pal-0.4.3-r2.ebuild
@@ -1,28 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit prefix toolchain-funcs
DESCRIPTION="Command-line calendar program"
-HOMEPAGE="http://palcal.sourceforge.net/"
+HOMEPAGE="https://palcal.sourceforge.net/"
SRC_URI="mirror://sourceforge/palcal/${P}.tgz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc x86 ~amd64-linux ~x86-linux"
IUSE="nls"
RDEPEND="
>=dev-libs/glib-2.0
- nls? ( virtual/libintl )
sys-libs/ncurses:0
sys-libs/readline:0
+ nls? ( virtual/libintl )
"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
+ nls? ( sys-devel/gettext )
"
RESTRICT="test" # Has no tests to run
@@ -45,15 +46,14 @@ src_prepare() {
}
src_compile() {
- cd src || die "failed to change to the src directory"
- emake CC="$(tc-getCC)" OPT="${CFLAGS}" LDOPT="${LDFLAGS}"
+ emake -C src CC="$(tc-getCC)" OPT="${CFLAGS}" LDOPT="${LDFLAGS}"
}
src_install() {
dodoc ChangeLog doc/example.css
+ newman pal.1.template ${PN}.1
- cd src || die "failed to change to the src directory"
- emake DESTDIR="${D}" install-man install-bin install-share
+ emake -C src DESTDIR="${D}" install-bin install-share
if use nls; then
emake DESTDIR="${D}" install-mo