summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/ganyremote
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/ganyremote')
-rw-r--r--app-mobilephone/ganyremote/Manifest2
-rw-r--r--app-mobilephone/ganyremote/ganyremote-6.0.1.ebuild26
-rw-r--r--app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild56
-rw-r--r--app-mobilephone/ganyremote/metadata.xml10
4 files changed, 94 insertions, 0 deletions
diff --git a/app-mobilephone/ganyremote/Manifest b/app-mobilephone/ganyremote/Manifest
new file mode 100644
index 000000000000..4c39b4d19588
--- /dev/null
+++ b/app-mobilephone/ganyremote/Manifest
@@ -0,0 +1,2 @@
+DIST ganyremote-6.0.1.tar.gz 280585 SHA256 14dda596fab59be899a3bcf815ba0c5938efdf83ba5f1d0d91b2f8bfc5ddb80c SHA512 04719a4c0e15bfe2aa670bd6b83ae300aee0a825733d0fb9f37ee98286520a7354f927fb4be4774acdd2a7251893e62d4ff3328f655567b87961a3f83542e7c0 WHIRLPOOL a8f23815d783a42b79f3a378c8bdeac10c368971a13365b7dc427e539fe558eb7b880f598484456ebd3a854cf715f7059c81b86bedcdfdb474cad86ec4408c7d
+DIST ganyremote-6.3.3.tar.gz 303612 SHA256 5033a261506b4c37ed5deed22428837d1c4b1e5cb0027234b2ec97f6e6d9b40d SHA512 cfb0d5896c3c4ee575f2d77d17b8f8e13624202100994415147f1ddb2b6c04c179ec4a4b31369830705ae1d0068e50fe0c3a5fd4acc2de6e02ec0a530a0a6182 WHIRLPOOL 0e8b8c3c6d9ffd8a77903fbf2a7e220d696eab4e609be5f684f7c2a9dab5a80f32d539d70203fd70d6a2a29e0f9ca9352d91442822830c9ccc4d230d79e56cae
diff --git a/app-mobilephone/ganyremote/ganyremote-6.0.1.ebuild b/app-mobilephone/ganyremote/ganyremote-6.0.1.ebuild
new file mode 100644
index 000000000000..f421fb5394a5
--- /dev/null
+++ b/app-mobilephone/ganyremote/ganyremote-6.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Gnome frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bluetooth"
+
+DEPEND=">=app-mobilephone/anyremote-6.0[bluetooth=]
+ dev-python/pygtk
+ bluetooth? ( dev-python/pybluez )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}
diff --git a/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild b/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild
new file mode 100644
index 000000000000..3f7ff95aaf65
--- /dev/null
+++ b/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-r1
+
+DESCRIPTION="Gnome frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-mobilephone/anyremote-6.5[bluetooth=]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ "${T}"/gettextize -f --no-changelog > /dev/null || die
+
+ # remove deprecated entry
+ sed -e "/Encoding=UTF-8/d" \
+ -i ganyremote.desktop || die "fixing .desktop file failed"
+
+ # fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am || die
+ eautoreconf
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i ganyremote || die
+ fi
+}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/ganyremote
+}
diff --git a/app-mobilephone/ganyremote/metadata.xml b/app-mobilephone/ganyremote/metadata.xml
new file mode 100644
index 000000000000..5ee3c69b838f
--- /dev/null
+++ b/app-mobilephone/ganyremote/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">anyremote</remote-id>
+ </upstream>
+</pkgmetadata>