summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-02 14:55:56 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-03 18:08:35 +0200
commite1d85c805e877677dcde6a7a819f150c3d5d7c2a (patch)
treea4fde7732711433d70ba4706a84de1b28d352674 /app-office/calligra-l10n
parentkde-apps/ktp-l10n: Migrate to L10N (diff)
downloadgentoo-e1d85c805e877677dcde6a7a819f150c3d5d7c2a.tar.gz
gentoo-e1d85c805e877677dcde6a7a819f150c3d5d7c2a.tar.bz2
gentoo-e1d85c805e877677dcde6a7a819f150c3d5d7c2a.zip
app-office/calligra-l10n: Migrate to L10N
Diffstat (limited to 'app-office/calligra-l10n')
-rw-r--r--app-office/calligra-l10n/calligra-l10n-2.9.11.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-office/calligra-l10n/calligra-l10n-2.9.11.ebuild b/app-office/calligra-l10n/calligra-l10n-2.9.11.ebuild
index 7c3cb845aa86..582a141997ee 100644
--- a/app-office/calligra-l10n/calligra-l10n-2.9.11.ebuild
+++ b/app-office/calligra-l10n/calligra-l10n-2.9.11.ebuild
@@ -34,8 +34,8 @@ SRC_URI=""
SLOT="4"
for MY_LANG in ${MY_LANGS} ; do
- IUSE="${IUSE} linguas_${MY_LANG}"
- SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.xz )"
+ IUSE="${IUSE} l10n_${MY_LANG/[@_]/-}"
+ SRC_URI="${SRC_URI} l10n_${MY_LANG/[@_]/-}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.xz )"
done
unset MY_LANG
@@ -45,19 +45,17 @@ src_unpack() {
local lng dir
if [[ -z ${A} ]]; then
elog
- elog "You either have the LINGUAS variable unset, or it only"
- elog "contains languages not supported by ${P}."
- elog "You won't have any additional language support."
+ elog "None of the requested L10N are supported by ${P}."
elog
elog "${P} supports these language codes:"
- elog "${MY_LANGS}"
+ elog "${MY_LANGS//[@_]/-}"
elog
fi
[[ -n ${A} ]] && unpack ${A}
cd "${S}"
- # add all linguas to cmake
+ # add all L10N to cmake
if [[ -n ${A} ]]; then
for lng in ${MY_LANGS}; do
dir="${PN}-${lng}-${PV}"