summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-09 13:51:21 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-09 13:52:48 +0100
commitee915dd2ddff2d87ba9abf876c5e612e92365aba (patch)
tree8bfcbd7e367490210ad5abd1651337433a58115a /app-office/orage
parentxfce-base/libxfce4ui: Bump to 4.18.2 (diff)
downloadgentoo-ee915dd2ddff2d87ba9abf876c5e612e92365aba.tar.gz
gentoo-ee915dd2ddff2d87ba9abf876c5e612e92365aba.tar.bz2
gentoo-ee915dd2ddff2d87ba9abf876c5e612e92365aba.zip
app-office/orage: Reintroduce, v4.18.0
Reintroduce the Orage calendar app, as upstream has resumed activity. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-office/orage')
-rw-r--r--app-office/orage/Manifest1
-rw-r--r--app-office/orage/metadata.xml8
-rw-r--r--app-office/orage/orage-4.18.0.ebuild60
3 files changed, 69 insertions, 0 deletions
diff --git a/app-office/orage/Manifest b/app-office/orage/Manifest
new file mode 100644
index 000000000000..2b18381ef034
--- /dev/null
+++ b/app-office/orage/Manifest
@@ -0,0 +1 @@
+DIST orage-4.18.0.tar.bz2 1418645 BLAKE2B 533f55d4a6e69c0458fb01a8b3fd6a20f30b409ddd1d2eb65f00c321daa441d7e99e154ee4558160fc3e387e2ddb45a2ee0c37e6814a74f40e724fd748cd2fa5 SHA512 7760219f64ac3e2ba6d73541a626a0c9411b93268c007f2af5d8080a3a3c0b2a08e00dd96b7794b688aa83c567150c02033b9ba46bf38cd71d3d890e8d1e45ad
diff --git a/app-office/orage/metadata.xml b/app-office/orage/metadata.xml
new file mode 100644
index 000000000000..dce6704738a4
--- /dev/null
+++ b/app-office/orage/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-office/orage/orage-4.18.0.ebuild b/app-office/orage/orage-4.18.0.ebuild
new file mode 100644
index 000000000000..f9d75fd99c9a
--- /dev/null
+++ b/app-office/orage/orage-4.18.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A calendar application for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/apps/orage/start
+ https://gitlab.xfce.org/apps/orage/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.58.0
+ >=dev-libs/libical-3.0.16:=
+ >=x11-libs/gtk+-3.24.0:3=
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ libnotify? ( >=x11-libs/libnotify-0.7.0:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}