summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2016-11-21 21:58:32 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-26 13:17:35 +0100
commit99d5c7ea86d44cb5959b70298f23c69aa1298aa6 (patch)
tree9d7cf6a29215ea3ed95b19ad714aae2a6690abc0 /app-office/worklog-assistant-bin
parentnet-misc/samplicator: fix shutdown of Google Code issue (diff)
downloadgentoo-99d5c7ea86d44cb5959b70298f23c69aa1298aa6.tar.gz
gentoo-99d5c7ea86d44cb5959b70298f23c69aa1298aa6.tar.bz2
gentoo-99d5c7ea86d44cb5959b70298f23c69aa1298aa6.zip
app-office/worklog-assistant-bin: New package
Worklog Assistant is a tool that helps you maintain logs of your activities related to JIRA issues which you can also push towards said JIRA instance. Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=600436 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2888
Diffstat (limited to 'app-office/worklog-assistant-bin')
-rw-r--r--app-office/worklog-assistant-bin/Manifest1
-rw-r--r--app-office/worklog-assistant-bin/files/worklog-assistant-bin-2.1.3577-fix-desktop.patch15
-rw-r--r--app-office/worklog-assistant-bin/metadata.xml12
-rw-r--r--app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3577.ebuild39
4 files changed, 67 insertions, 0 deletions
diff --git a/app-office/worklog-assistant-bin/Manifest b/app-office/worklog-assistant-bin/Manifest
new file mode 100644
index 000000000000..3b2cfdaccf91
--- /dev/null
+++ b/app-office/worklog-assistant-bin/Manifest
@@ -0,0 +1 @@
+DIST worklog-assistant-v2_2.1.3577_amd64.deb 31450392 SHA256 200c59c3301b04267387324ec8505908b424ea14e5324275717f1e08bcaeda58 SHA512 17445e4b3b77f5ff7c4ed4fad30569b4037830769010cf4d4d6fd15a0ac2524983864fdd1ca435eff97155150ef56992e95f759cf047642135bdb35d7dbb7b75 WHIRLPOOL 61895868dc2c0181cbc3f45f2efe4fe8bea8affeff22bbd35a0b1c7c71e2bc6b567188fb86d000ea646e819b5c2f9e686d34ac2d9eb6664b6c79565f85fb4257
diff --git a/app-office/worklog-assistant-bin/files/worklog-assistant-bin-2.1.3577-fix-desktop.patch b/app-office/worklog-assistant-bin/files/worklog-assistant-bin-2.1.3577-fix-desktop.patch
new file mode 100644
index 000000000000..850707f589f8
--- /dev/null
+++ b/app-office/worklog-assistant-bin/files/worklog-assistant-bin-2.1.3577-fix-desktop.patch
@@ -0,0 +1,15 @@
+The .desktop file wrongly indicates the version of the software instead of the
+version of the .desktop file format. This has been reported upstream and should
+be fixed in the next version.
+
+--- "a/usr/share/applications/Worklog Assistant.desktop"
++++ "b/usr/share/applications/Worklog Assistant.desktop"
+@@ -3,7 +3,7 @@
+ [Desktop Entry]
+ Type=Application
+ Name=Worklog Assistant
+-Version=2.1.3577
++Version=1.0
+ Comment=Hassle-free time tracking for JIRA
+ Exec=/bin/bash "/opt/Worklog Assistant/bin/wrapper.sh"
+ Icon=/opt/Worklog Assistant/share/logo.png
diff --git a/app-office/worklog-assistant-bin/metadata.xml b/app-office/worklog-assistant-bin/metadata.xml
new file mode 100644
index 000000000000..72530b22b19e
--- /dev/null
+++ b/app-office/worklog-assistant-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mathy@vanvoorden.be</email>
+ <name>Mathy Vanvoorden</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3577.ebuild b/app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3577.ebuild
new file mode 100644
index 000000000000..e5e0a2c220cf
--- /dev/null
+++ b/app-office/worklog-assistant-bin/worklog-assistant-bin-2.1.3577.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit unpacker
+
+MY_PN="${PN%-bin}"
+
+DESCRIPTION="Hassle-free time tracking for JIRA self-hosted and OnDemand"
+HOMEPAGE="https://worklogassistant.com"
+SRC_URI="https://worklogassistant.com/downloads/${MY_PN}-v2_${PV}_amd64.deb"
+
+LICENSE="worklog-assistant"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+RESTRICT="fetch strip"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-desktop.patch"
+)
+
+src_prepare() {
+ default
+
+ rm -r etc/ || die
+ rm _gpgbuilder || die
+}
+
+src_install() {
+ mv * "${ED}" || die
+
+ dosym "/opt/Worklog Assistant/bin/Worklog Assistant" /opt/bin/WorklogAssistant
+}