summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-13 18:13:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-13 18:15:42 +0100
commita5275a338fde7320a814fd31537a9f125983e3a9 (patch)
tree0024a30c2316908b9bec7d2cc8f397b2d1bd7dcb /app-portage
parentmedia-sound/gigedit-1.1.1-r1: fixes (diff)
downloadgentoo-a5275a338fde7320a814fd31537a9f125983e3a9.tar.gz
gentoo-a5275a338fde7320a814fd31537a9f125983e3a9.tar.bz2
gentoo-a5275a338fde7320a814fd31537a9f125983e3a9.zip
app-portage/gentoopm: Bump to 0.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoopm/Manifest1
-rw-r--r--app-portage/gentoopm/gentoopm-0.3.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-portage/gentoopm/Manifest b/app-portage/gentoopm/Manifest
index 66a2e53b32e1..c958c5109877 100644
--- a/app-portage/gentoopm/Manifest
+++ b/app-portage/gentoopm/Manifest
@@ -1 +1,2 @@
DIST gentoopm-0.3.0.tar.gz 37614 BLAKE2B c848c08677c4ac5ab0fdc1499045ae418048ec35d4ef925d1fe09ab4b68ec90e4f6843511efc29184883f3b3582bd3de519212bea1997736378b01bdc13ebd14 SHA512 e2a82f37b9a42688b6dd7023accdbf537780069deb6ca6ec6d9e159baf774af17e2a405c9eb40105b73b165f1c8c2ccde3ed685e04a61c9cd6665d1677da61d3
+DIST gentoopm-0.3.1.tar.gz 37897 BLAKE2B dd5499787bcc5c46ae3b559f3af4a5af5b4ca81a312e926149c587cac0391c51dbe61ac42d2bc19eb83cedc168486e9c30ddd6fbf4ae10ffd9719aefa2f54cd3 SHA512 e1a3a7929ae83d813dd0b03f0548f033e8e51b766aaddb653027398fb618819de6237e2ba1c0542defc9d62e71e8495aa10152cbc47a4e521f7cbaeda3ea4354
diff --git a/app-portage/gentoopm/gentoopm-0.3.1.ebuild b/app-portage/gentoopm/gentoopm-0.3.1.ebuild
new file mode 100644
index 000000000000..dbdac94b858a
--- /dev/null
+++ b/app-portage/gentoopm/gentoopm-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="https://github.com/mgorny/gentoopm/"
+SRC_URI="https://github.com/mgorny/gentoopm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
+PDEPEND="app-eselect/eselect-package-manager"
+
+python_test() {
+ esetup.py test
+}